Sonoff touch V2.1 Tasmota - help!

Hi All,

I recently got a Sonoff touch, it’s the V2.1EU. But I’m having problems flashing Tasmota onto it. I’ve tried jumping R19 to ground, but this still makes it boot normally and not info flash mode, and SonOTA doesn’t seem to work either.

I’m using the pins just above the touchpads to flash with.

Any help would be appreciated!

Haven’t tried that switch, yet.

However it looks as if the flash port is the one on the right side. The one labeled GRD, TX, RX , 3V3.

Hope it helps.

Good spot, tired me just went for the first ones I saw! It does seem to be a weird switch, I can’t see anyone online flashing these yet.

Just to follow up, the pins on the right are correct for flashing, thanks @Akriss! And jumping the small pad labeled ‘T1’ puts this device into flash mode, I was then able to put Tasmota on it.

Hi Fred!

May I ask which firmware you used? I have the same unit (single switch version) and flashed the standard “tasmota.bin” file but I guess that is not the correct one as it just sticks on the D4 LED on boot. Any info would be appreciated.



Did you apply the correct template ?

Hi Francis, thanks for the reply. I couldn’t get to apply the templete as no WiFi SSID from the unit is being broadcast after the flash, I think I may have uploaded the incorrect firmware and bricked it. It’s my first attempt at this and finding the exact model I have is proving to be tricky whoever, the photo that Fredd589 posted is exactly the same as mine except mine is a single switch, if I understand correctly, the template should be applied once connected via WiFi after a flash on the web console?
Thanks for the input and patients!

@JTG7600, if you boot it up without any jumpers attached can you still toggle the switch with the touch buttons? I used tasmota.bin, then once booted and connected to wifi changed it to the Sonoff Touch3. The one your using does sound correct.

Did you have any problems when flashing it?

Hi Freddie, yes you are correct, I was trying to test it while still connected the the FT232-USB adapter. I followed your suggestion and re-assembled it then gave it power. It does indeed work now. Thanks a lot for the help guys! Appreciate it!

Hi! Sorry but jumping to where? I soldered one wire to TP1 but other side? GND? GPIO0 through R19? Should I keep it permanently during flash or just at boot to enter flash mode? Thanks for your support!

The one in the read square in the picture above should be connected to GND when inserting your FTDI-adapter in the USB, so the ESP enters flash mode.


I bought very simillar wallswitch, but it’s not actually from Sonoff. Except, looks more or less EXACTLY the same (just there is lightbulb icon on touch button).
For me TP1 didn’t work, however TP2 made the job :slight_smile: Just right to TP1.