Sonoff zbdongle throwing off devices (but why?)

Situation / Snapshot:

  • we currently have 27 devices connected to our Sonoff zbdongle (E).
  • our zbdongle is connected to a windows-server (virtualbox, “inside” a Intel-N100 mini-pc with 16GB RAM - so, lots of processing & space headroom).
  • our server is RJ45-wired.
  • and our zbdongle is placed appr. 1 meter away from the PC, to minimize signal-interference.
  • and it is all placed high and centrally (to minimize signal-losses).

I cannot see, that there is anything, that could lead to “devices getting unavailable”:

  • which although nearly ideal conditions DO happen - actually we have only had it all up running fror appr. 1 week now! … and 2 times, I have had to reinitialize / power-down (remove batteries, ro get home-assistant to work together with some of the devices again (not the same devices, and batteries was fine, and their distance to the dongle was less than 10 metres).

Batteries: Are new and branded, and does NOT lack juice (I have tested this, on a separate unit!).
(I changed ALL batteries here in sept’2023, in all our Sonoff’s, with good ones from Varta & Energizer - because a test-sample bought in 4 months ago, already had the included “noname” battery nearly flat).

My own hope & solution - since nearly all units are Sonoff (their simple sensors & contacts):

  • is to get a Sonoff zigbee-bridge, and split the devices in 2 …
  • in order to have each brigde only having to handle 13-14 devices (with good headroom up to the official /appr. 32-device limit)!
  • and also having the 2 bridges /coordinators a bit away from each other (appr. 2 rooms apart).

But, will adding no. 2 bridge help?, or am I dealing with another problem-cause here?
27 devices being close to “Sonoff’s 32-device limit” is the only reason, I can think of - but I am rather inexperienced, and our “home-assistant smart-home solution” is only a few weeks old!

(PS: We have a Philips Hue also, and its deevices “just works” very stable! the Hue-bulbs has been rock-steady, ever since we installed them 3 years ago … which is IN DEEP CONTRAST TO the home-assistant run devices, connected through our “Sonoff zigbee zbdongle E”!
(even using our overly-strong PC-Server!!!)

What zigbee channel is your Sonoff using.

What channel number is your 2.4Ghz wifi usin?

(no these channel id’s don’t map to each other - different tech) but wifi can ABSOLUTELY interfere with zigbee.

I agree 10 feet is pretty short so you have either a signal interference issue or something going on.

The 32 endpoint limit is only ‘direct connected’ devices but zigbee is a mesh network. Powered nodes (not battery nodes) usually repeat for the network. The more you add the stronger it gets. So yeah you might be near that but if any of your nodes are repeaters… This is important because.

There can only be one coordinator per zigbee network. Your hue is also zigbee yes but it’s got it’s own network going on. If you wanted to add another coordinator you’d have yet another network. Nobody gets critical mass for the repeaters. And this would have nothing to do wit how ‘powerful’ your server is.

As to how ‘stable’ the Sonoff endpoints are I will leave that to someone with more experience with thier devices. But I see mixed comments about the devices themselves.

Get your channels as mentioned above to rule out rf interference and what does your log say?

thanks for reading my long description, and getting back to me.

I have checked, regarding channels:

  • the LAN-wifi-mesh runs at 2462MHz (wifi channel 11).
  • the Zigbee dongle, runs at 2405MHz (zigbee channel 11)
  • so frequency/interference-wise, they are nearly “as far away” from each other as possible.

Regarding zigbee-mesh/repeaters:

Then it’s not a wifi channel interference issue either. (you’re correct I usually reccommend ‘all 11’ for that very reason and it’s easy for folks to remember) sounds like you’re in a good spot as far as the physical setup.

Id say at this point you’re probably looking at something unique with how those specific devices are communicating or specific settings. It’ll take logs. Unfortunately I don’t have any Sonoff to tell you about the specifics of those devices.

1 Like

Then you are close to the theoretical maximum of 32 devices

Ideally, you want something like this :

2 Likes

and - interference-wise:

We live in a 1-level house, in the countryside - away from farms (i.e. we have no strong EMI/EMC-signals around us) - so we have little to no interference from neighbourgs etc…

So - my suspicion is:

  • either the Sonoff’s are purely unstable (the battery-compartment of the “window/door-detectors” are also not designed well! - which can lead to power-connection ripples/challanges, a mechanical issue, which I have “corrected”, in order to “force” a stable battery/power-connection) !!!
  • or the zigbee-dongle has got problems, and therefore renders random devices unavailable.

Or - we have a problem within our home-assistant… causing it to render devices unavailable.
(PS: I have tried reconfiguring the “unavailable” devices - to no avail!)

The dongle:

  • I am in doubt, if I am “just” struggling, because of an erratic firmware-version?
  • or, that our zigbee2mqtt xx will not start - well I don’t understand this, so I might be telling garbage, but (see picture)HA - zigbee2mqtt - not running

If you only have one dongle, it is either ZHA or Zigbee2mqtt, you can’t use both at the same time.

Never works with end-devices, unless you wake them first

2 Likes

I am not sure about how to interpret your map/example, exect that it looks cool! and with a lot of devices bought & connected…

but, a realistic solution for me, is to get a stand-alone bridge (from sonoff) … and, then just split the devices (removing some from the dongle, and adding these to the stand-alone bridge) - getting appr. 14 endpoint-devices connected directly to each.

We don’t have so much mony, to spend (due to homeschooling, and only 1 income) - so I cannot just go out and buy big.

(and the sonoff zigbee bridge is cheap… just as their end-devices are cheap)

My stupid/elementery question then is: How do I find out, which of these I have got /am using?
(because, my son has helped me, with it all . and he is not available to help me now).

And, I try to understand it all, as good as possible…

And he has been struggling with the zigbee2mqtt (the picture) …
with me, trying to keep up …
(I know my way around frequences, wifi, etc - but not the cool sw-world etc of home-assistant)

Just disconnect a Hue bulb or two, and add them to your dongle network might already make a huge difference.If your sensors work, and the add-on is not started, you are using ZHA

2 Likes

thanks - I also “thought” so, but I wasn’t sure (actually I thought, tha the zongle by default just did “zigbee2mqtt” and that the error was due to an extra service, not wanting to “cooperate”.

but - I am a bit reluctant to switch the hue-bulbs from the super-stable hue-solution, and over to the erratic /work-in-progress dongle-solution…

But - in order to seek out the cause of the problem, I will probably have to do so …

the long-term solution to me, seems to be, to buy a stand-alone Sonoff zigbee bridge, and then split the sonoff end-devices between the usb-dongle & stand.alone-bridge… and have the hue’s work stable (with their stable hue-bridge)!
(because I don’t want the hue’s to become unstable, unavailable, etc - we need them every-day …)

Or buy 2 of these:
https://www.aliexpress.com/item/1005005237205282.html

Which just complicates the solution without any verification that your coordinator stick is at fault. I’m with Francis. Move a hue bulb or get some repeaters. If that doesn’t help take a good hard look at the sensors you chose.

That coordinator dongle is quite popular and many people use it with no issue.

thanks … a good idea.

And, a repeater is the thing, at least on paper …
I just thought, that why not separate things - and make sure the small dongle doesn’t have to do too many serial communication tasks … well then I could 100% separate the communication tasks…

thinking in the same way, as with for instance wifi-access.points - where I have 2 LAN-wired Mesh AP’s, with each one ONLY dealing with some units …
That works 100% …

Going “through” the dongle, after being repeated, just doesn’t seem to offload anything - to me, as a HW-technician, a repeater only re-outputs the signal, and probably in doing so, creates “an ecco” (leading to new signal interference problems)

Adding routers as suggested would be the first step

The next thing I would try is a ZBDongle-P to replace the E.

I’ve had better experience with the P in general.

But with either P or E, a few routers are still recommended.

1 Like

It is not a “repeater” (that is the wrong technical name), it is a Zigbee Router, and that is not what a Zigbee Router device does. Zigbee Router will consolidate messages from devices behind it and as such off load the Zigbee Coordinator and build out the Zigbee network mesh. Zigbee depends on “network mesh” technology to expand the network with more devices. Read → https://www.home-assistant.io/integrations/zha#using-router-devices-to-add-more-devices (and https://www.home-assistant.io/integrations/zha#introduction)

Follow tips here about avoiding interference and adding more “known good” Zigbee Router devices → Guide for Zigbee interference avoidance and network range/coverage optimization

I use a Sonoff Dongle-E and its been rock solid. I live in a three story house, with the dongle situated on the bottom floor.

To begin with, I’d track something like the LQI score of each device and see how they are affected during the day. For example:

In ZHA this is a hidden entity you can enable for every device.

Or you can use something like the ZHA network card:

To give you more info.

I have a mix of repeater and end devices, totalling about 60 in all, and rarely have any issues.

yes - but the problem here is that somewhere in the
longer software-chain, something goes wrong.

and that can be anywhere in the chain - since things has ro ooperate, so-to-speak

So you are certain its nothing to do with signal strength or interference, you’ve ruled that out ?

I’m not just talking about WIFI vs Zigbee channels, but other RF interference that can come from house hold appliances, usb3 ports etc.

It absolutely is not the coordinator (unless you have a faulty one), as my network, using the same coordinator is rock solid.

yes.
as a hw-technician, I am 100% sure.

and, I don’t question rhe dongle.

I question the SW-chain