Sonoff ZBMini-L randomly turning off?

Hi,

I have 4 Sonoff ZBMini-L with ZHA using a Sonoff Dongle Plus 3.0 as coordinator and 3 router devices and my ZBMini-L are randomly turning off.

They are no randomly turning on just off and it doesn’t seem to be a signal problem since I manage to get LQI about 90 on each device and as soon one of the lights turn magically off I can turn it on HA, also HA signal that it was “Turned off” no “Turned off by some logic on HA”.

And at iTead product page are people reporting the same:

Does anybody has this random turn off problem ?

BTW I already reported this to iTead support.

TIA

1 Like

Hello,

I have the same issue with multiple zbmini L devices ordered from itead. Did you get an answer from the supplier?

Yes. They finally found that there is problem with their firmware and are working to release an update. Question is how are going to apply that firware with HA :slight_smile:

1 Like

New 1.1.1 firmware for ZBMINI-L is now available from Sonoff/ITead.

Can be delivered OTA using HA if you carefully follow the instructions.

1 Like

Also see related discussion here:

https://community.home-assistant.io/t/sonoff-zbmini-l-zigbee-3-0-smart-switch-by-itead-works-without-neutral-wire-and-based-on-cc2652p-so-should-be-a-good-zigbee-router/384644/

FYI, ITead have just release a new firmware for Sonoff ZBMINI-L that is meant to address delay issues:

https://github.com/Koenkk/zigbee-OTA/tree/master/images/Sonoff

https://github.com/zigpy/zha-device-handlers/issues/1519

Originally posted by @Daniel-zhan-itead in [Device Support Request] ZBMini-L delayed response after minutes of pairing. Workaround found on Zigbee2MQTT · Issue #1519 · zigpy/zha-device-handlers · GitHub

We have raised the pull request for the OTA update image on github Pull requests · Koenkk/zigbee-OTA · GitHub.
Once it is approved, you can download the image and update the ZBMINI-L devices.

Originally posted by @Daniel-zhan-itead in [Device Support Request] ZBMini-L delayed response after minutes of pairing. Workaround found on Zigbee2MQTT · Issue #1519 · zigpy/zha-device-handlers · GitHub

Feature: Added Poll Control Cluster private attribute 0xFF00 (enable/disable configuration), the default Poll Control Cluster initial configuration is disabled
Bugfix: Random shutdown issue

Hi all,

Did the problem above disappear for you?

Have a similar problem with my ZBMINI-L: it seems to work fine with switch and Zigbee2MQTT, BUT it has an endless cycle of automatically turning the lights on and off in some 5-10 second cycle.

Anyone else experiencing such problem?

Lars

Same problem here. Have you solved it?

Not yet - forgot to test without the momentary switch connected, but if I recall correctly, that works fine.

Is this the same for you ?

Lars

Same here. Without push button everything is ok.

Indeed. I’ll try to contact Sonoff support, maybe I’ll order a second one to rule out the one I received is broken.

I ran a test on a separate system and the zbmini-l seems to work correctly.
In my case I think there are problems in the electrical system of the house. There is an inconsistent low voltage between “S2” and “L in” causing the zbmini-l to turn on and off. Bad news for me.

Thanks for reporting. I will check the same in my installation and get back.

Same random on/off on 1.1.1 firmware in 2-3 min cycles. Sometimes the kitchen, sometimes a room other side of the house. It makes no sense.

Support responded, mentioning that the cable length to the switch shall not exceed 6m. Maybe that is helpful for some who hae issues.

Lars