Sonoff ZBMini-L randomly turning off?


I have 4 Sonoff ZBMini-L with ZHA using a Sonoff Dongle Plus 3.0 as coordinator and 3 router devices and my ZBMini-L are randomly turning off.

They are no randomly turning on just off and it doesn’t seem to be a signal problem since I manage to get LQI about 90 on each device and as soon one of the lights turn magically off I can turn it on HA, also HA signal that it was “Turned off” no “Turned off by some logic on HA”.

And at iTead product page are people reporting the same:

Does anybody has this random turn off problem ?

BTW I already reported this to iTead support.


1 Like


I have the same issue with multiple zbmini L devices ordered from itead. Did you get an answer from the supplier?

Yes. They finally found that there is problem with their firmware and are working to release an update. Question is how are going to apply that firware with HA :slight_smile:

1 Like

New 1.1.1 firmware for ZBMINI-L is now available from Sonoff/ITead.

Can be delivered OTA using HA if you carefully follow the instructions.

1 Like

Also see related discussion here:

FYI, ITead have just release a new firmware for Sonoff ZBMINI-L that is meant to address delay issues:

_Originally posted by @Daniel-zhan-itead in [Device Support Request] ZBMini-L delayed response after minutes of pairing. Workaround found on Zigbee2MQTT · Issue #1519 · zigpy/zha-device-handlers · GitHub

We have raised the pull request for the OTA update image on github Pull requests · Koenkk/zigbee-OTA · GitHub.
Once it is approved, you can download the image and update the ZBMINI-L devices.

_Originally posted by @Daniel-zhan-itead in [Device Support Request] ZBMini-L delayed response after minutes of pairing. Workaround found on Zigbee2MQTT · Issue #1519 · zigpy/zha-device-handlers · GitHub

Feature: Added Poll Control Cluster private attribute 0xFF00 (enable/disable configuration), the default Poll Control Cluster initial configuration is disabled
Bugfix: Random shutdown issue

Hi all,

Did the problem above disappear for you?

Have a similar problem with my ZBMINI-L: it seems to work fine with switch and Zigbee2MQTT, BUT it has an endless cycle of automatically turning the lights on and off in some 5-10 second cycle.

Anyone else experiencing such problem?


Same problem here. Have you solved it?

Not yet - forgot to test without the momentary switch connected, but if I recall correctly, that works fine.

Is this the same for you ?


Same here. Without push button everything is ok.

Indeed. I’ll try to contact Sonoff support, maybe I’ll order a second one to rule out the one I received is broken.

I ran a test on a separate system and the zbmini-l seems to work correctly.
In my case I think there are problems in the electrical system of the house. There is an inconsistent low voltage between “S2” and “L in” causing the zbmini-l to turn on and off. Bad news for me.

[UPDATE Feb 15 - I’m not allowed to put more than 3 replies in this topic… :nauseated_face:]

Just bought some ZBMINI-L2 (wow, they are extremely small!!!) and in the same installation that was causing me problems, they work.
I did a quick test, need time for more thorough testing.

Thanks for reporting. I will check the same in my installation and get back.

Same random on/off on 1.1.1 firmware in 2-3 min cycles. Sometimes the kitchen, sometimes a room other side of the house. It makes no sense.

Support responded, mentioning that the cable length to the switch shall not exceed 6m. Maybe that is helpful for some who hae issues.


I’m experiencing the same.

I have 8 zbmini-l devices and they all work well except for 3 of them.

Here is my experience:

I connect it all up correctly. My zbmini-l devices is inside my ceiling though, not behind my switches, and I run cables to the S1 and S2 from the switch.

If I turn on the lights at the switch, it all works immediately, no delays. The lights stay on.

When I turn off the switch, the device seems to automatically turn the lights on and off in a random fashion. Usually around the 2-minute mark.

It does not happen with all of them, just the 3, and im unsure why.

I’m experiencing the same issue mentioned in this thread. My device is a Sonoff ZBMINI-L2, and since installation, it turns off randomly after a few minutes without any apparent reason. Here are some details about my setup:

  • Device: Sonoff ZBMINI-L2 Zigbee
  • Firmware Version: 0.0 (not displaying any other version)
  • Hub: Multi-Mode Gateway Tuya Wireless Zigbee 3.0 Hub

Firmware version shows 0.0, and I couldn’t find any updates

The device was installed by a professional electrician. I would appreciate any insights or suggestions on how to resolve this issue. Also, do you recommend using a different hub for better compatibility and performance?

I don’t know if the issue is with the hub. Would it help if it were connected to a hub using the eWeLink app instead?