Sonoff Zigbee 3.0 usb flash issues

Hi there, I’m trying to flash my sonoff 3.0 zigbee usb stick as I’ve read in numerous places it is a good idea to do this rather than just leaving it stock before setting it up with home assistant. I plan on using zigbee to mqtt.

I’m wondering if i’m reading outdated instructions, or doing something wrong altogether. I’ve tried to flash the stick using Smart RF Flash programmer 2, and with 2 different sonoff sticks, it does not show up as a connected device after holding the boot loader button and plugging it into my windows computer to flash.

It shows as a Sonoff zigbee 3.0 USB dongle plus in device manager but it does not have it’s drivers installed. I saw in a video to try and update the driver by letting windows search but it immediately finds nothing.

Wondering if anybody can see where I may be faltering…Thanks in advance for any help

Driver issue

1 Like

OK I feel dumb, I even saw that video…This can be deleted, thank you!

:man_facepalming: that driver is no longer available… It is hosted on someone’s Synology drive

I tried to install it from the instructions in the sonoff pdf update guide.

you shouldnt feel dumb, because you are not alone now.
thank you @tteck this helped me a alot.

I have te exact same problem, I’m following Mark Watt’s How-to guide and my dongle doesn’t show up in Smart Programmer. Doesn’t matter witch button I use when inserting. Tried it on two Windows 10 machines.

Hello, i tried to flash Sonoff but it it not going in boot mode. I watched the video but in the optional updates i do not have Silicon Laboratories do be downloaded. Any idea ?

Windows Update is freaky. Update all of the optional updates, reboot, check for updates, rinse and repeat until silicon labs comes up. If not you should be able to point the driver locator to the install path and it hopefully will pick up the driver binary there.