Sonoff Zigbee 3.0 USB Plus issues


I installed (plugged in) my Sonoff zigbee stick 2 days ago and it was detected immediatly in HA.
Managed to set it up without any issues.

I ordered 7 Aqara P1 motion sensors for my house and 2 innr smartplugs, mainly for the router function.

I added all devices, without any issues, everything was working, however, after about 30 minutes HA is throwing errors for the Sonoff stick.

Home Assistant Core
Error setting up entry Sonoff Zigbee 3.0 USB Dongle Plus - Sonoff Zigbee 3.0 USB Dongle Plus for zha
13:56:57 – (ERROR) components/zha/core/
Couldn’t start ZNP = Texas Instruments Z-Stack ZNP protocol: CC253x, CC26x2, CC13x2 coordinator (attempt 1 of 3)
13:56:57 – (WARNING) Zigbee Home Automation - message first occurred at 13:56:46 and shows up 3 times

I tried to uninstall it and re configure, but whenever I try to configure the stick and try to set up a new network, HA just shows a box with Error and nothing else.

I was wondering, in the first place, why this suddenly happened (is it because I just added everything and did not change anything to the Zigbee network?)
And also, how can I get the stick to work again?
I’ve seen topics that say you need to reset the NVRAM, other topics say you need to reflash the stick …

I’m pretty lost as I have never used Zigbee before and I don’t want to mess up stuff even more.

I haven’t used that USB radio, but I would suggest re-plugging the USB dongle and/or restarting the machine. But I don’t know why it should have happened at all. (I use ConBeeII USB dongles and haven’t had that problem, but I’ve only read good things about the Sonoff ones.)

1 Like

Hi, thx for the reply.
I’ve already replugged the stick, restarted HA, even restored my back up from last night when it was still working. Should’ve added that to the first post.

I think the problem is with the stick itself :frowning:

Typically, to reflash the dongle, you’d need to remove the case, by first removing the tiny screws. Then there are two buttons on the board inside. One is RESET the other is to ENABLE flashing. You guessed it, hold down the ENABLE button while connecting the dongle to your USB port. Then use the python utility to load the correct firmware.

Now, there’s a thread here somewhere, I’ll see if I can find it for you. It contains all the links to download the python utility and the firmware.

1 Like

Also follow Guide for Zigbee interference avoidance and network range/coverage optimization

1 Like

Thanks for the replies, I reflashed it and seems to be working again now.
Maybe a small tip for someone else who needs to re-flash, if Windows update does not find a driver for the stick, Iobit’s driver updater was able to install the driver for me.

@Hedda thanks for the extensive guide, I didn’t know Zigbee is so sensitive.

Maybe one more question, do I just leave this as it is or do I need to link the devices to the closest Zigbee router?