Sonoff Zigbee 3.0 USB Plus - Zigbee2MQTT will not start

Hi all, I’ve had a Sonoff USB Plus dongle working with HASS running on a Pi3 under ZHA for a while now. I want to play around with Frigate, and so I’m trying to get Zigbee2MQTT running.

Mosquito Broker is up and running, but every time I try to start Zigbee2MQTT it hangs on starting zigbee-herdsman.

Config for Zigbee2MQTT is:

data_path: /config/zigbee2mqtt
  enabled: false
  master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
  slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
  options: "-d -d"
  log: true
mqtt: {}
  port: /dev/ttyUSB0

Which seems correct given my hardware. Error logs for when I try and start the add on are as follows:

[21:21:51] INFO: Preparing to start...
[21:21:53] INFO: Socat not enabled
[21:21:59] INFO: Starting Zigbee2MQTT...
Zigbee2MQTT:info  2024-04-18 21:22:23: Logging to console and directory: '/config/zigbee2mqtt/log/2024-04-18.21-22-22' filename: log.txt
Zigbee2MQTT:info  2024-04-18 21:22:24: Starting Zigbee2MQTT version 1.36.1 (commit #unknown)
Zigbee2MQTT:info  2024-04-18 21:22:24: Starting zigbee-herdsman (0.40.3)
Zigbee2MQTT:error 2024-04-18 21:23:48: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2024-04-18 21:23:48: Failed to start zigbee
Zigbee2MQTT:error 2024-04-18 21:23:48: Check for possible solutions
Zigbee2MQTT:error 2024-04-18 21:23:48: Exiting...
Zigbee2MQTT:error 2024-04-18 21:23:48: Error: Failure to connect
    at Ezsp.connect (/app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/ezsp.ts:373:19)
    at Driver.startup (/app/node_modules/zigbee-herdsman/src/adapter/ezsp/driver/driver.ts:171:13)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:132:29)
    at Zigbee.start (/app/lib/zigbee.ts:62:27)
    at Controller.start (/app/lib/controller.ts:109:27)
    at start (/app/index.js:107:5)

So far I’ve switched USB ports, disabled ZHA, uninstalled ZHA, added a USB extension cable, all to no avail. If anyone has any advice or can see something in the logs I’m missing, I’d really appreciate the advice!


This should be /dev/serial-by-id/[your adapter]. You should avoid using /dev/ttyUSB* completely.

You have a Plus and not a Plus V2 ? then try

  port: /dev/ttyUSB0
  adapter: zstack

But keep in mind what Bill said in the answer above.

1 Like

This should be /dev/serial-by-id/[your adapter] . You should avoid using /dev/ttyUSB* completely.

Thanks for the advice. I’ve changed it, sourcing the adapter info from the hardware section, but nothing has changed. It still fails at the same step in the logs.

port: /dev/ttyUSB0
adapter: zstack

@francisp I’m quite sure it’s not the v2; I tried the change you suggested including the port Bill suggested, but it still fails at the same startup point :frowning:

You do know you have to disable ZHA to get Zigbee2MQTT running on your stick if you only have one stick ?

Yep! I mentioned that in the troubleshooting I’ve tried. Unfortunately it made no difference.