Sonoff Zigbee devices constantly going offline

I have 4 Sonoff Zigbee alarm sensors - one DS01 door sensor and 3 MS01 PIR motion sensors. They all paired with my ZHA integration, using a Sonoff Zigbee Bridge, but they all regularly show as being offline in Home Assistant (core v2021.7.4).
I’m getting a bit bored of having to go around and remove/repair one sensor or another every few days.
Has anyone else had this problem with Sonoff Zigbee sensors?

I have a Sonoff motion sensor that never show a route, but every time I pass it show motion. Maybe you just have to wake them ?

I’m not able to wake my sensors. For example if I trigger a PIR sensor I see the red LED flash but it doesn’t trigger my automations and remains offline in HA.

ok, the pir is still awake. Doe you have other Zigbee devices in your Zigbee network ?

No - just the Sonoff alarm sensors and the hub

Problem is possibly the hub :

Consider using zigbee2tasmota instead (uses mqtt)

Jeez I had no idea that the hub was flakey with wifi - I never saw mentions of that when I was researching it on here.
Presumably zigbee2tasmota would require some specialist hardware to flash the Sonoff Zigbee Bridge? I’ve tried to avoid that sort of thing in the past!
Is there an ethernet Zigbee bridge that is tried and tested with HA?

If you are using it with ZHA, it must already be flashed ? Afaik the zbbridge does not work with ZHA out of the box.

Yes it was pre-flashed with Tasmota.

Then you can simple disable the ZHA integration and try zigbee2tasmota instead.

https://tasmota.github.io/docs/Zigbee/

Sonoff ZbBridge (75) is set as the default module. If you’re switching back to Zigbee2Tasmota from ZHA make sure module is configured back to 75.

Just to clarify some of the background to this issue…my understanding is that there are problems with Zigbee devices co-existing with wifi networks (which surprises me, given how prevalent wifi has become in homes these days). But anyway…
(How) would zigbee2tasmota help with these problems?

That is not the main problem (the coexistence is easily solved by having your wifi channel(s) on one side of the 2.4 spectrum, and your zigbee channel on the other side). The reason for that is EZSP (EmberZNet Serial Protocol) is not a robust protocol in the way that it appears not to be designed to handle the type of packet loss that can often occur on home WiFi networks.

With ZHA you have
zigbee device ->(zigbee) → zbbridge → (serial over wifi) → zha interpreting the zigbee messages → HA

With zigbee2tasmota you have
zigbee device → (zigbee) ) → zbbridge (tasmota interpreting thezigbee messages) → (mqtt over wifi) → mqtt → HA

The zigbee messages are no longer transported over (serial over ) wifi, but read on the zbbridge themselves.

Another way to cut down on the conversions and hops would be to use a USB Zigbee controller in the device running HA. I use the HUSBZB and have been very satisfied with my growing network of Zigbee devices.

I did think about a USB controller, but my setup is complicated by the fact that (a) I’m running HA in a guest VM on an ESXi host and (b) in a Docker container.
I had problems a couple of years ago connecting a USB device to one of the guest OS’s and never revisited the idea.

Well, there are other options to continue using ZHA and not having an USB stick :

and probably more.

Thanks for those recommendations. I’m based in the UK - do you happen to know if the Zig-star ships to the UK? (it’s out of stock at the moment, but the price is quoted in Euros, which suggests it’s not exclusively for US customers). I can’t find any indication on the website re. where the supplier is based.
Does anyone have any experience of configuring a Zig-star for use with HA? e.g. does it require any specific hardware, and is it relatively straightforward for a non-expert to do?
I’ll give zigbee2tasmota a try in the meantime. I’ve just repositioned my Sonoff hub to place it further away from the wifi access point, to see if it helps, but from what you’ve said it probably won’t.

1 Like

Better ask @mercenaruss

Hi @itm1960 ,yeah we ship to UK or any another part of the world.
Now of course we are out of stock,will be back soon as possible. Working hard on it.
I send preflashed and tested,it’s very simple configuration,just one line in your Z2M config or ZHA.

I’ve been checking out zigbee2tasmota in the meantime, and have configured the Sonoff Zigbee Bridge module to ZbBridge(75 ). I’ve tried pairing each sensor using the ZbPermitJoin command, and they appear on the Tasmota map - see below.
For some reason 2 of the sensors aren’t connected to the Coordinator - I have no idea why. I also don’t see any new devices in my HA Developer Tools console. Do I need to manually add entries to configuration.yaml for each of my sensors?