Sonoff Zigbee Dongle-E - Zigbee2MQTT Host Fatal Error

Hey guys,

I think I know the answer, but maybe need your confirmation.

I’m struggling to get my Sonoff Dongle-E to work again after stupidly flashing it with the Multiprotocol firmware after I had it working with the latest Zigbee firmware.

This is my current issue, after to reflashing back to

[16:56:22] INFO: Preparing to start...
[16:56:22] INFO: Socat not enabled
[16:56:23] INFO: Starting Zigbee2MQTT...
[2024-06-11 16:56:25] info: 	z2m: Logging to console, file (filename: log.log)
[2024-06-11 16:56:25] info: 	z2m: Starting Zigbee2MQTT version 1.38.0 (commit #unknown)
[2024-06-11 16:56:25] info: 	z2m: Starting zigbee-herdsman (0.49.2)
[2024-06-11 16:56:25] info: 	zh:ember: Using default stack config.
[2024-06-11 16:56:25] info: 	zh:ember: ======== Ember Adapter Starting ========
[2024-06-11 16:56:25] info: 	zh:ember:ezsp: ======== EZSP starting ========
[2024-06-11 16:56:25] info: 	zh:ember:uart:ash: ======== ASH NCP reset ========
[2024-06-11 16:56:25] info: 	zh:ember:uart:ash: RTS/CTS config is off, enabling software flow control.
[2024-06-11 16:56:25] info: 	zh:ember:uart:ash: Serial port opened
[2024-06-11 16:56:25] info: 	zh:ember:uart:ash: ======== ASH starting ========
[2024-06-11 16:56:28] info: 	zh:ember:uart:ash: ======== ASH NCP reset ========
[2024-06-11 16:56:28] info: 	zh:ember:uart:ash: ======== ASH starting ========
[2024-06-11 16:56:30] info: 	zh:ember:uart:ash: ======== ASH NCP reset ========
[2024-06-11 16:56:30] info: 	zh:ember:uart:ash: ======== ASH starting ========
[2024-06-11 16:56:33] info: 	zh:ember:uart:ash: ======== ASH NCP reset ========
[2024-06-11 16:56:33] info: 	zh:ember:uart:ash: ======== ASH starting ========
[2024-06-11 16:56:35] info: 	zh:ember:uart:ash: ======== ASH NCP reset ========
[2024-06-11 16:56:35] info: 	zh:ember:uart:ash: ======== ASH starting ========
[2024-06-11 16:56:38] error: 	z2m: Error while starting zigbee-herdsman
[2024-06-11 16:56:38] error: 	z2m: Failed to start zigbee
[2024-06-11 16:56:38] error: 	z2m: Check for possible solutions
[2024-06-11 16:56:38] error: 	z2m: Exiting...
[2024-06-11 16:56:38] error: 	z2m: Error: Failed to start EZSP layer with status=HOST_FATAL_ERROR.
    at EmberAdapter.initEzsp (/app/node_modules/zigbee-herdsman/src/adapter/ember/adapter/emberAdapter.ts:850:19)
    at EmberAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/ember/adapter/emberAdapter.ts:2683:24)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:127:29)
    at Zigbee.start (/app/lib/zigbee.ts:62:27)
    at Controller.start (/app/lib/controller.ts:109:27)
    at start (/app/index.js:107:5)

Seems to be failing at the ASH start up.

Is there a way back, or have I bricked my brand new dongle? :smirk:

is the multiprotocol add-on still running ?
ZHA is not enabled ?
Did you try a different USB-port ?

Hey Francisp,

I uninstalled all of the addons I had added after realising I’d broken everything.

Cuurently have it connected to an extension cable, it is showing up in the Hardware section, but I will try pluging directly into different ports.

P.S. I’m running in a Proxmox VM, I believe I passed through the device as a USB device, rather than a specific port.

Tried the different ports and same error.

I had ZHA disabled before (couldn’t get it to reconfigure either). I just uninstalled it, upon pluging the dongle back in ZHA popped up again to be configured.

If ZHA pops up, your dongle is found. Maybe try the ezsp driver first.

Tried both, to no avail.

When I had got it working it was by updating the firmware to the latest and using “ember” as the adapter.

I’ve just run an ls -l of the /dev/ folder and ttyACM0 isn’t even there, but there is a ttyACM1 which is where the device is.

Are both packages expecting to communicate on ttyACM1 or should they be looking for the specific device id?

Sorted it… :man_facepalming:

Thanks for your suggestions @francisp. It was connecting to another VM that I tried to use to flash it with and not shut down.