Sonoff Zigbee Dongle Plus (ZBDongle-p) not connecting to HA on VMWare VM

I’ve been trying to connect my ZBDongle-P to my home assistant but it doesn’t seem to detect any new USB devices, I’ve tried the USB 2.0 ports on my laptop as well as my USB 3.0 hub. I’m using VMWare Workstation Pro 17 to run home assistant OS, VMWare seems to detect the USB but home assistant isn’t. What’s the problem?

The issue has been fixed! The problem was my VMWare configuration after going through a rabbit hole of fixes. Here are the steps if your having the same issue:

1. Power-down the VM Guest.
2. Go to the Guest VM main folder on your comptuer and search for the following file: <the name of your guest Virtual Machine>.vmx
3. Edit this file and search for a line that states: usb.restrictions.defaultAllow
- Most likely you will have it set to "FALSE"
4. If so, please change it to "TRUE"
It must look like this: usb.restrictions.defaultAllow = "TRUE"
5. Save and close the text editor.
6. Start VM Guest and try it out. The first thing you will notice is a pop-up windows with a list of all USB devices, something you did not see before.

I’m having the same issue, I’m using the ZBDongle-E connected to a VMware ESXi 7, I’ve tried everything I know and still not detecting, I have other sort of USB devices connected to the same host and works fine, I’m just wondering if its not compatible with VMware, appreciate any help.