sonoffLAN Cloud Light Cannot change brightness

Tags: #<Tag:0x00007f3265feb0e8>

Hi,

Thanks for reading, I have a number of E27 Edison style bulbs. They’re in eWelink and can’t be flashed with Tasmota. on the eWelink app I can control the brightness and the colour of white eg bright or warm. This also works in Google and Alexa.

I am using AlexxIT SonofLAN to get the bulbs into HA. They appeared as switches and have changed them to lights. However, within HA I cannot for the life of me figure out how to change the brightness. I have tried from the lights service and the sonoff send command and neither work.

I have had to create a virtual door contact in SmartThings which runs a routine in Alexa to overcome this challenge but this is really fiddly!

The light is recorded as the following:

manufacturer: FortuneShip
model: FS-1
sw version: WTW-705-GL v1.4.8
cloud: online

Any ideas?

Thank you for your help.

Why can’t they be flashed? All the sonoff devices i I have were flashable.
I didn’t tried it but doesn’t the normal sonoff integration work? Or does it need a cloud connection?

Hi, it depends on the chip on the LED bulb, these ones do not have the ESP8266 chips and can’t be flashed. With AlexxIT/sonoffLAN it will try and find them on the local LAN and if not found use the cloud. These particular ones are cloud and not actually sonoff. I have some of the sonoff mini USB devices, they too can’t be flashed but have been automatically discovered on the LAN.

Well I have the same bulb, and are facing the same problem.
I have tried to look at the AlexxIT/SonofLAN code but haven’t found a solution yet.
Keep me posted if you find a solution.

Hi,

Yes, I got nowhere at all! The best I could do was to use a SmartThigs simulated opener to trigger a routine in Alexa to set the brightness, then another one to set it back. Not pretty at all, but it does work.

Likewise, let me know if you figure it out.

First do this to make HA recognize the bulb, as a Light, and not a switch:

Edit: /config/custom_components/sonoff/utils.py, and look for this line:

         102: 'binary_sensor',  # Sonoff DW2 Door/Window sensor

Add this line below it:

         103: 'light',  # CCT bulb (B02 or FS-1)

Now there is no need to have this in the “/config/configuration.yaml” file:

#Comment out these lines by adding # in front of them
  devices:
    1000a1b2c3:
      device_class: light
      name: FS-1 Bulb (1)
    1000a4b5c6:
      device_class: light
      name: FS-1 Bulb (2)

Now rename /config/.sonoff.json, to .sonoff.json.bak
Restart Home assistant.

I think I have some working code now at:
https://github.com/thomasadelhardt/SonoffLAN