Sonos Crossfade?

Tags: #<Tag:0x00007fc41d258508>

I’ve only started with Home Assistant for a week but I am very impressed.

I can’t see it anywhere and was wondering if the ability to turn CROSSFADE on/off was available for the media_player (sonos) ?

Thanks.

There is currently no way to do this though it should be relatively easy (for a Python programmer) to add it to sonos.set_option.

1 Like

Thanks @amelchio Fingers crossed it comes along later.

Just to let you know that there is a custom component which can be installed using HACS here https://github.com/jeremywillans/sonos-crossfade

Cam confirm that it works with the current version of Sonos and Home Assistant

1 Like

Hi im new to home assistant I have added the sonos_crossfade to the hacs

restart server and tried to add config to the configuration.yalm

sonos_crossfade:
    entity_id: media_player.kontor
    enabled: true'

but it is not working anybody can tell me how this is setup correct for a newbie.

After adding in HACS the only entry you need in configuration.yaml is:

sonos_crossfade:

After a restart sonos_crossfade.update becomes available to use as a service e.g.

service: sonos_crossfade.update
data:
  entity_id: media_player.lounge
  enabled: true

yes got it thanks

my HASS did also not restart correct.