Sonos integration does not find anymore my speakers (same vlan as HA)

I have been running Home Assistant via its official docker image on a Raspberry Pi 4 for some years. Recently, I switched over to an Intel N100 machine and moved the docker container and its configuration there. It has been running smooth and everything immediately worked from the start.

However, there is only one integration that has stopped working since the moving: the Sonos one. I have 3 speakers, a soundbar and a woofer from Sonos.

When I was on the Raspberry Pi 4, Home Assistant automatically found all those devices by itself. Now I don’t receive anymore the notification but even trying to “manully” add the speakers by going to Integrations → Sonos, I get a “No devices found on the network” message.

The speakers are on the same vlan (I only have one) and I can ping them all from my N100 machine where Home Assistant is running.

Do you know what I am doing wrong and how could I re-add them into Home Assistant? I really don’t understand what is going on.

For the moment, I temporarily solved by manually adding the speakers in my configuration.yaml as indicated in the Home Assistant Sonos integration page (Sonos - Home Assistant).

I remain waiting for the real solution, which would be to fix the autodiscovery. I am using network_mode = host in my docker container.