SONOS - No Sonos devices found on the network

Hi Guys,

For a while, it`s impossible to me to add the SONOS components. I always have an error mentioning “No Sonos device for on the Network.”

Any idea what can be causing this ? I tried the old way with the configuration.yaml and now with the integration tab but still I never get any speakers.

I`m open to suggestion thanks!

I`m running version 111.2 at the moment.

Danny

Running 114.2 and the issue is still there… I`m also curious is there a limit for the number of speakers ?

What does your network look like? Usually firewalls, Docker or separate VLANs are involved where there are issues like this.

Im using only one subnet (my Sonos are in the same subnet as my home assistant and Im on a flat VLAN). I used to have my HASS in a PI (I had the same issue). I moved to Ubuntu with Docker and issue is still there. I also tried with a fresh install and… same problem. They used to work and they just stopped suddenly. By the way, no firewall is in the path.

Thanks!

For Docker, be sure to use the --net=host setting. If that doesn’t help, try enabling Sonos logging and send me the logs (my e-mail address in on my GitHub profile or you can put it somewhere and PM me a link).

logger:
  default: info
  logs:
    homeassistant.components.sonos: debug
    pysonos: debug

Hi,

Just to be certain where do you put --net=host, in the configuration.yaml file ?

Thanks again for your help,

Danny

PS: I also added the information you mentioned in my config file.

Oh … don’t run with that logger configuration permanently, it will generate a lot of logs. Just enable it, restart Home Assistant, copy the log file, remove the configuration and restart again.

The --net=host is an option to Docker, mentioned in the top box here: https://www.home-assistant.io/docs/installation/docker/

Hi amelchio,

There is an extract of the error I`m getting for every speakers I have.

2020-08-25 11:19:11 DEBUG (Thread-5) [pysonos.services] Received {‘CONTENT-LENGTH’: ‘347’, ‘CONTENT-TYPE’: ‘text/xml; charset=“utf-8”’, ‘EXT’: ‘’, ‘Server’: ‘Linux UPnP/1.0 Sonos/58.1-79200 (ZPS1)’, ‘Connection’: ‘close’}, <s:Envelope xmlns:s=“http://schemas.xmlsoap.org/soap/envelope/” s:encodingStyle=“http://schemas.xmlsoap.org/soap/encoding/”><s:Body><s:Fault>s:ClientUPnPError501</s:Fault></s:Body></s:Envelope>
2020-08-25 11:19:11 DEBUG (Thread-5) [pysonos.services] Received status 500 from 10.0.0.191
2020-08-25 11:19:11 DEBUG (Thread-5) [pysonos.services] Error b’<s:Envelope xmlns:s=“http://schemas.xmlsoap.org/soap/envelope/” s:encodingStyle=“http://schemas.xmlsoap.org/soap/encoding/”><s:Body><s:Fault>s:ClientUPnPError501</s:Fault></s:Body></s:Envelope>’
2020-08-25 11:19:11 DEBUG (Thread-5) [pysonos.discovery] Error handling discovery response, ex=UPnP Error 501 received: Action Failed from 10.0.0.191
2020-08-25 11:19:11 DEBUG (Thread-5) [pysonos.discovery] Received discovery response from (‘10.0.0.174’, 51376): “b’HTTP/1.1 200 OK\r\nCACHE-CONTROL: max-age = 1800\r\nEXT:\r\nLOCATION: http://10.0.0.174:1400/xml/device_description.xml\r\nSERVER: Linux UPnP/1.0 Sonos/58.1-79200 (ZPS18)\r\nST: urn:schemas-upnp-org:device:ZonePlayer:1\r\nUSN: uuid:RINCON_48A6B8826E8C01400::urn:schemas-upnp-org:device:ZonePlayer:1\r\nX-RINCON-HOUSEHOLD: Sonos_830xqkNC8tdUFBVuv1GRd8ueGd\r\nX-RINCON-BOOTSEQ: 49\r\nBOOTID.UPNP.ORG: 49\r\nX-RINCON-WIFIMODE: 0\r\nX-RINCON-VARIANT: 2\r\nHOUSEHOLD.SMARTSPEAKER.AUDIO: Sonos_830xqkNC8tdUFBVuv1GRd8ueGd.Ys3JvtobjY3KA44qJIWH\r\n\r\n’”
2020-08-25 11:19:11 DEBUG (Thread-5) [pysonos.services] Sending GetZoneGroupState [] to 10.0.0.174
2020-08-25 11:19:11 DEBUG (Thread-5) [pysonos.services] Sending {‘Content-Type’: ‘text/xml; charset=“utf-8”’, ‘SOAPACTION’: ‘urn:schemas-upnp-org:service:ZoneGroupTopology:1#GetZoneGroupState’}, <?xml version="1.0" ?>
<s:Envelope xmlns:s=“http://schemas.xmlsoap.org/soap/envelope/” s:encodingStyle=“http://schemas.xmlsoap.org/soap/encoding/”>
<s:Body>
<u:GetZoneGroupState xmlns:u=“urn:schemas-upnp-org:service:ZoneGroupTopology:1”/>
</s:Body>
</s:Envelope>

2020-08-25 11:19:11 DEBUG (Thread-5) [pysonos.services] Received {‘CONTENT-LENGTH’: ‘347’, ‘CONTENT-TYPE’: ‘text/xml; charset=“utf-8”’, ‘EXT’: ‘’, ‘Server’: ‘Linux UPnP/1.0 Sonos/58.1-79200 (ZPS18)’, ‘Connection’: ‘close’}, <s:Envelope xmlns:s=“http://schemas.xmlsoap.org/soap/envelope/” s:encodingStyle=“http://schemas.xmlsoap.org/soap/encoding/”><s:Body><s:Fault>s:ClientUPnPError501</s:Fault></s:Body></s:Envelope>
2020-08-25 11:19:11 DEBUG (Thread-5) [pysonos.services] Received status 500 from 10.0.0.174
2020-08-25 11:19:11 DEBUG (Thread-5) [pysonos.services] Error b’<s:Envelope xmlns:s=“http://schemas.xmlsoap.org/soap/envelope/” s:encodingStyle=“http://schemas.xmlsoap.org/soap/encoding/”><s:Body><s:Fault>s:ClientUPnPError501</s:Fault></s:Body></s:Envelope>’
2020-08-25 11:19:11 DEBUG (Thread-5) [pysonos.discovery] Error handling discovery response, ex=UPnP Error 501 received: Action Failed from 10.0.0.174

Thanks,

Danny

1 Like

For others who find this thread: my problem was I had a firewall on my raspberry pi. I tried a bunch of allow based on ports that sonos said to open, but it didn’t work.Then I just turned it off and all was good: sudo ufw disable

1 Like

Do you have a lot of speakers (more than 20 I think)?

1 Like

Yes, 32. Could it be the problem?

It seems like it, I found this issue with the same error message in the supporting library: https://github.com/SoCo/SoCo/issues/518. Apparently, the number of groups cannot exceed about 20.

It is possible to fix the library but that requires a developer with access to such a big system.

Let’s hope someone will fix it one day :frowning:

It’s just not possible for me to use Sonos with HASS the way it’s implemented right now. :frowning:

How does it work it I am using docker? What to change before Sonos can be seen?

It is hard to say what to change when you don’t tell what you currently have.

You must enable host networking (see the note at the top of Installation - Home Assistant ) and disable any local firewall. Sonos and Home Assistant should be on the same VLAN.

1 Like

When configuring Sonos Integration via yaml, you can specify hosts by IP address - this lets Sonos to be found across VLANs. This manual ability to add IPs would be helpful in the UI based config.

2 Likes