Sonos not playing mp3 anymore


I had my doorbell always working but now all of a sudden it doesn’t work anymore. It will not play my mp3 anymore on my Sonos speakers.

When i try to use developer tools services then I run the following yamls:

service: media_player.play_media
  media_content_id: https://URL/local/doorbell/Doorbell.mp3
  media_content_type: music
  entity_id: media_player.kantoor

The URL for the mp3 is accessible and working.
When I run this then i see in the UI for the device that it is playing this mp3. But no sound is there.
Also no error logs or any logs at all :frowning:

Anybody an idea what could be wrong? or what i can do else to debug?

What version of HA are you running?

I’m on 2021.8.3 and mine still works fine.

I think I remember seeing reports of this on the latest version and I think there a bug report submitted.

I have the same issue. You might see an error message in the Sonos app.
(like I do). I my case I think Duckdns could be the issue but I have not found a solution yet.

I also don’t use DuckDNS.

I use Nabu Casa.

Using the latest version and no duckdns. Today continuing with debugging.

Where do you see the message in Sonos?

So it has something to do with my proxy. When i use the internal IP then it works.

investigating further since the URL can be accessed and is working from a browser without issues.