Last night I was struggling with google TTS through my sonos. I could’t figure out what was wrong. In case your are stuggling too. It might help what sonos logs.

This was the issue:

  • tts worked when NOT using ssl
  • I tried the correct base_rul since 0.35.x and with or without serverport in the http config

What might help you solving your problem is that you can check your SONOS logs by accessing it in a browser:

I found out that in my situation the certs where not valid. I fixed that (using letsencrypt), but sonos still reported ssl validation errors. Probably a caching thing. After a reboot of all the players and using the following base_url it was working:

ssl_certificate: /etc/letsencrypt/live//fullchain.pem
ssl_key: /etc/letsencrypt/live//privkey.pem
base_url: :8123

(Yes, in my situation has version 0.36.1 i still needed serverport in base_url)

1 Like

More SONOS “hidden” webinterfaces urls can be found here:

I get the following error:

[1970-01-21 11:44:35.949] <certval,1> (pass 1) local cert validation failed (27) for
[1970-01-21 11:44:36.397] <certval,1> (pass 2) remote validation failed with result 27 with ttl 300 for
[1970-01-21 11:44:36.398] <ssl,1> SSL connect error -0x2700 11 to
[1970-01-21 11:44:36.424] <certval,1> (pass 1) local cert validation failed (27) for
[1970-01-21 11:44:36.425] <certval,1> (pass 2) remote validation failed with local cache hit 27 for
[1970-01-21 11:44:36.425] <ssl,1> SSL connect error -0x2700 11 to
[1970-01-21 11:44:36.426] <chsrc,0> Transport error ERROR_LOST_CONNECTION for account type 0, URI:, friendly name: 9e7609d004e4703e1ae14b532277bb432912fe7e_no_-_google.mp3, share/server:, path:, ip:, host:, extra info: , http: -1, framer: mp3

certificate from letsencrypt. If i copy the url to a browser i can hear the mp3 file