"Sorry, something went wrong for 5 lights..."

Tags: #<Tag:0x00007fc3ebaa86b8> #<Tag:0x00007fc3ebaa8488>

Using Naba Casa + Google Assistant and it works pretty well except when trying to turn on/off multiple lights at once. In my kitchen I have 5 Zigbee lights (4 identical Ledvance recessed lights and 1 Philips Hue light). When I say “Hey Google, turn off the kitchen lights”. maybe 60% of the time it works and I just get a ding from Google Assistant. The rest of the time the lights will turn off, there will be a pause, and Google Assistant will say “Sorry, something went wrong for 5 lights” despite it working. The same applies for turning the lights on.

Is this just a side effect of the commands to the lights having to run through several layers of abstraction before communication with Google and any latency or lag that might be going on at the time, or am I missing something?

3 Likes

Did you some this? Mine has started to act up. It executes all actions but still says “Sorry, something went wrong with X lights”.

Negative. It still happens and I pretty much gave up on troubleshooting.

There has to be more people experiencing this…?

This is happening to me as well. I’ve been ignoring it for a while, but decided to try to figure out what was happening today. I don’t see anything wrong. You say, turn on one light, and it’s lightening fast. You ask for multiple, the delay is 5+ seconds, then the lights turn on/off, and Google tells me something went wrong.

Yeah that’s my experience too. One light or device turning on/off is fine, but saying “turn off the kitchen lights”, where 5 lights are in the Kitchen group in HA, its a 50/50 shot whether Google will say something went wrong. Even though it turns the kitchen lights off just fine.

I’m also experiencing this with inovelli switches, nabu casa, and the Google Assistant integration. My only guess so far is Home Assistant isn’t returning until it turns off all the lights, so Google gets fed up and says something went wrong. It only happens if we try to turn of all the lights, single rooms work fine

I’m experiencing the same issue. This used to be a problem only when I was turning off all the lights in the house, but more recently it’s gotten to the point where even zones with five or more devices result in Google Assistant responding with “Sorry, something went wrong”.

I haven’t been able to find a published timeout for the response to the action.devices.EXECUTE intent, but it seems to be in the area of about 8 seconds. In practice I don’t think that’s possible to achieve when trying to control a significant number of devices on a large Z-Wave network.

Ideally, Google would provide something like a “pending” response type that could be proactively be used when needed. No, it’s not ideal, but it’s better than hearing “Sorry, something went wrong” every time a user tries to do something.

This is not just a Google issue, it happens with Alexa too. The only things that is the same is Nabu Casa.

I opened a case with Nabu Casa to at least get some clarity here, if not a fix. I’ll report back here if I learn anything useful.

2 Likes

I opened a support case using the exact text from my first post above, and here was their reply:

“Is this just a side effect of the commands to the lights having to run through several layers of abstraction before communication with Google and any latency or lag that might be going on at the time”

This probably contributes to an already existing problem Google has, yes. There are many results when searching for this response outside of the HA platform.

It comes and goes for me, though lately I haven’t experienced this response in several months. I believe that the more entities involved in a single command, the more hardware an entity needs to go through (another hub), the more likely you are to experience it.

There are suggestions out there for checking that your home location is set correctly within the Google Home app, and disabling IPv6. I do have IPv6 disabled on my HA host, but I’m not sure that comes into play. My location has always been set.

My home address is set in the Google Home app, and I just disabled IPv6 on the Ubuntu server I’m using to host HA. I’ll report back if anything changes.

Nothing really changed with the above effort. I swapped 4 Zigbee recessed lights for 4 Zwave ones and that seems to have made the process of turning all 5 lights on or off much faster. Now Google doesn’t seem to feel the delay means it didn’t work so I don’t get any complaints about anything going wrong. I’m using zwave2mqtt as well FWIW.

I’m probably going to switch to zigbee2mqtt as well and I’ll try to report back if that resolves the issue as well.

I have Nabi casa and Google home

Also getting the same issue as you described. If I ask to turn off/on a single light then the result is quick and the Google home plays a confirmatory ‘chime’. However if I issue a command like “Ok Google, turn off the lights” in which Google will attempt to turn off all lights it knows to be in the same room, the lights turn off and then after 5 seconds or so the home responds “Sorry, something went wrong turning off two lights”.

Perhaps the home is expecting 2 confirmations and only receives 1?

Edit: The issue appears to be intermittent