Sound Card Troubles on vmware ESXi using PCI Passthrough

Has anyone been able to get a sound card working on ESXi (I’m using 7.0) using PCI passthrough?

I have created a VM using the OVA image and added the sound card (SB1570 Audigy Fx) as a PCI device. Everything seems to work just fine, except the sound card is not detected. I cannot find much of interest in the logs, other than notices that no cards were found.

Creating a VM using the VMDK file behaves identically. However, an Ubuntu VM is able to detect the card without issue, so I do not think it is a fault with ESXi.

The following may not be relevant, but it is where I’m at…

Ubuntu appears to be using the snd_hda_intel module to load the card, but that module does not appear to be loaded in HA. Actually, lsmod only lists a single module, xfrm_user. Is that true, or what am I missing?

Looking at the operating-system source for the nuc, I see the follwing entries in buildroot-external/board/intel/nuc/kernel.config:


However, the corresponding OVA file (operating-system/blob/dev/buildroot-external/board/intel/ova/kernel.config) does not have any CONFIG_SND_ entries.

I tried loading the snd_hda_intel module using the instructions found here. The .conf file is created in /etc/modules-load.d/, but I do not see that the module is loaded.

Is the snd_hda_intel module actually being used and I’m looking in the wrong place? If it is not loaded, could that be my issue? If so, how do I proceed?

My apologies in advanced if I’m way off base. This is well out of my realm.

Edit: Yes, I can probably install HA using docker in a VM, but I’m stubborn, I feel like this should work, and would really like to understand what is going on.

In case anyone stumbles upon this in the future…

The lack of PCI sound kernel modules (listed in above post) in the OVA kernel was indeed the issue.

After a crash course in Buildroot and some very helpful documentation, I was able to build an OVA with the required kernel modules. A new VM, created from the newly built OVA, recognized the sound card immediately.

I have since submitted a pull request which was merged, so hopefully this is not an issue for anyone in the future.

I’m using VDMK image on vmware workstation, updated to 5.3 and added soundcard, but nothing show under hassos audio hardware, any idea ?

Any idea ?
I’m using integrated realtek chipset, added virtual sound card in vmware and updated to 5.3, but still no soundcard detected by hassio…