Speedtest integration slow in HASSIO inside a VM


After using HA in docker on my Synology NAS DSM918+ for the last 2 years, I decided to switch to HASSIO inside a VM on the same Synology NAS (Zigbee2mqtt and DSM 7).

Strangely the results of my speedtest integration with HASSIO very slow compare to my previous test done with the same integration in HA inside Docker.

To be sure I run a new speedtest inside a standalone docker on the same NAS and get full speed.

docker run --rm --net=host tianon/speedtest

    Latency:     1.13 ms   (0.09 ms jitter)
   Download:   932.23 Mbps (data used: 419.1 MB)                               
     Upload:   810.03 Mbps (data used: 576.8 MB)  

My result with the speedtest integration inside HASSIO is more around 250 Mbps

I tried to run speedtest inside NodeRed in the HASSIO and a get similar results

Screen Shot 2021-10-06 at 21.38.50

I run speedtest inside NodeRed in my original installation inside Docker and a test better result (not yet full speed).

Screen Shot 2021-10-06 at 21.47.17

Thanks in advance for any help!

Maybe try to run a speedtest in another VM than HassOS, to pinpoint whether the issue is in the image or in your VM setup…

1 Like

Thanks for your subjection.

Sorry for the delay, it takes me time to set up a new VM (Ubuntu).
The speed test on the VM work at full speed.

So the problem comes from HA VM or Speedtest integration.
Any other opinions?

Assuming that running a test via nodered doesn’t use the integration, that leaves only the ha VM itself…

Yes, the problem should come from the VM.

I didn’t try to install Speedtest CLI on HA VM.
Except for this, I’m out of options.