Speedtest is changed

Yesterday I had the right values… Today it shows download around 8Mbps while my download is around 30Mbps…
I dont know what happened… I didnt change anything

based on this: https://home-assistant.io/blog/2016/08/28/notifications-hue-fake-unification/#hotfix-0271---august-30 looks like now you can select the server to perform the test against but I’m unable to find anything in the docs …

The documentation for speedtest was updated but not deployed.


thank you @fabaff,

How can I get the Server ID? I’ve been playing a bit in the speedtest.net page but I can’t find a list of servers vs server ID.

Here you can find the list of servers: https://www.speedtest.net/speedtest-servers.php

1 Like

I guess that it would help if that link is included in the documentation.

I added also an ID, it still gives totally wrong values, now its around 4Mbps while I’ve around 30Mpbs! :frowning:
I also executed sensor.update_speedtest… Seems it is totally not reliable.

What about this one? https://home-assistant.io/components/sensor.fastdotcom/

I think is the one used by Netflix to measure bandwidth but I have not tested it.

@davedan I just tried it, but it doesn’t even show in my frontend. I added sensor.fastdotcom to my groups, and created the sensor, and did the manual update by executing the service sensor.update_fastdotcom… the sensor doesnt show in my frontend… I also tried to give it another name… not working…

I’m having the same issue. Was working fine but suddently it dropped from 90MB/Sec. to btw. 4-8 MB/Sec.

Anybody that found a fix for it?

Maybe a problem with your service provider and the node connecting it to the speedtest server?

I didn’t see any issue with mine:

i’ve noticed the same as @KBrygger all of a sudden the speed is really slow going to try fast dot com to check if it is the same

Do you guys maybe all live in the same area :yum::thinking:

Did you try to see what result you get from www.speedtest.net ?

I live in Belgium you @KBrygger? :slight_smile: speedtest tested on laptop is good. but hass is running from pine64.
Fast gives 95.7Mbit/s speedtest gives 17Mbit/s that’s a big difference

@Sennevds - I’m from Denmark.

Strange thing happens. Now it works like normal, didn’t change a thing.

Could you open an ssh tunnel to your pine64 and then try again?
Or simply try with on of the cli version of speedtest:

I’ve tried that and it got the same result so it’s not hass but the cli itself

Could the server on which hass is running have a bad connection to internet?

Did you change anything at your infrastructure? Maybe try to download a file from your server to see how fast the internet is (to see if it’s really a speedtest/cli issue, or simply an issue with your connection)

when i use fast.com I get a much higher speeds so it is a problem of speedtest itself

That’s weird, if your computer give the good result it can also not be from speedtest itself. And if other speedtest give good result on the server it cannot be the server. Remain the cli runner, but no reason for it to cause any difference… did you try already specifying a target server.