Speedtest runs at start, can that be disabled?

Hi,
Before the 2023.1: Happy New Year of the voice! - Home Assistant release ran the speedtest using an automation. After the release I had to disable the polling for updates to stop it from testing every hour, but I cannot stop it from running a speed test at the startup of HA.

Does someone know how to disable all “self triggered speed tests” ?
This is all I could find and what I disabled. :arrow_down: Did I miss something?

image

Since the change

Same here, anybody have an idea to stop self running speedtests?

Steffen

If enable polling for updates is disabeld there is no self triggert update and there is no update with the automation running several month fine with homeassistant.update_entity.

So how we can only run a Speedtest to special times and not all the day?

Steffen

The hourly run is described in the release notes I added in the opening post.
It writes:

The update frequency option has been removed. The default frequency is now 60 minutes. If you like to customize the polling: disable polling update from system options and use the update_entity service in an automation to manually update it at your own custom schedule.

This topic is about the fact that speedtest runs after a restart of HA.

Yes I know, but I do not want to self running every 60 minutes and not after a restart. I use a automation update the entities to run a Speedtest on a special time and do not want more.