Speedtest suddenly slow on my Pi

The speedtest component is suddenly reporting very slow on my Pi that I’m not seeing elsewhere. The Pi, hardwired into my router, is reporting around 23Mb/s whereas everything else is reporting 45Mb/s. This suddenly happened at 2am two nights ago where it went from fine to dreadful - no action on my part. speedtest.cli has the same issues.

I’ve replace the network cable and the port on the router is Gb. Anybody else suffering the same?

Have you tried changing the server ID? You can find the list and ID Here

Here is my config

    minutes: 30
    - ping
    - download
    - upload
  server_id: 3227

Sadly I’ve tried several - including switching to one that was working fine on my laptop. No dice.

Have you tried restarting the Pi?

My download has been bad for a couple of weeks now - usually shows around 200meg but have seen around 80meg. This is on a 3b+ hard wired to my router. Speedtest on my phone was normal. That’s when I changed the server ID on my config.

I’ve rebooted everything, changed out cables, changed servers. Nothing seems to help

Perhaps the port is busy?

Do you have network throughput sensors?

- platform: systemmonitor
  - type: throughput_network_in
    arg: enp2s0   ### Change to your hardware port
  - type: throughput_network_out
    arg: enp2s0   ### Change to your hardware port

No I don’t.

As you can see mine is also playing up again so I guess there is some issue with this integration at the moment

Add the system throughput sensors. Perhaps something is hogging your home assistant bandwidth.