SRT321 ZWave Thermostat Setpoint still not supported - and winter is approaching fast

I chose to move to the OpenZWave approach to running my running ZWave network. The network is used to control a series of power switches and two thermostats. Initially, the thermostat wasn’t supported: but hey it was Spring and I didn’t need the heating on.

It’s now early Autumn and I’m starting to get worried: have I f*cked a primary role for my HA?

There was a long-running Issue on github that covered the SRT321. The SRT321 is now partially supported, but only the battery-state entity. The issue has been closed but the setpoint is still missing.

I raised a new issue in August: but it’s not getting any attention. I’ve bumped it a couple of times, but nada. I guess it’s not considered to be important enough.

That’s OK provided I can roll back to what used to work.

So, can I go back to the way ZWave used to be supported?

@freshcoast posted a work around in your issue, have you tried it?

Thanks! @firstof9. It makes sense, but I’ve no idea how I would implement the change. I’m running on hassos and can’t see any way to modify the python files in the addon.

Monitor this PR:

1 Like

Thanks for linking this in, @firstof9; and for your efforts to fix the problem.

Should be sorted in 0.116 :slight_smile:

1 Like

Close, but no cigar - yet :slight_smile:

The air temp appears, but there’s still no setpoint (aka climate). I see sombody has bugged this in Github.

His issue doesn’t specify if they’re running the beta, have you tried the beta yet?

I thought it was all beta?? Or did you mean dev?

0.116 is currently in beta testing

Sorry, my bad. I saw 0.116 and read 0.115.6. I’ll try the “beta” of 0.116.

Another user has reported that it fixes their Horstmann SCSC17 thermostats, which seem to have the same issue as yours, so :crossed_fingers:

Good news. The thermostat setpoint appears with 0.116.0b4.

All I need to sort out now is the associations on the thermostat. The stat used to control one of the heater switches directly, but it’s lost the assocation and the openzwave addon UI doesn’t seem to support that functionality. However, that’s a separate issue and a new thread :slight_smile:

Thanks for your help.

It can be done via mqtt commands, feel free to pop on discord in #zwave there’s many examples in the chat history.

OK. Thanks again.