SSD installation on Raspberry Pi 4 failing

Hi together,

I followed this guideline:

My setup:

  • Raspberry 4, 2GB
  • keyboard, monitor
  • SATA adapter and HDD, tested with current Raspberry OS → working there
  • hassos 5.9 and 5.9 x64 tested
  • balenaEtcher to copy the image to HDD

Raspberry is booting, but sticking with a black screen for hours.
I just found there is already an image 5.10, I will also test this.

Any ideas what might still be wrong? I’m sure the boot from USB / MSUSB is working, so it should be something in the image or copy of the image?

First up, does the Pi boot Raspberry Pi OS off an SD card. And if yes, how about off the HDD?
This just is to confirm the hardware is all OK, but also allows us to check the EEPROM firmware version on your Pi.
If it does boot Raspberry Pi OS, can you run:

vcgencmd bootloader_version

In the terminal and post the output?

Edit 1: Raspberry Pi OS might update the EEPROM when you first boot it, so it could actually solve the boot issue :crossed_fingers:
So if the firmware version is November 2020 or newer, try booting Home Assistant again

The guide is about SSD, not HDD. Don’t know, if this makes any difference. Also on the guide:

Did you check all of this?


oh, that’s quite fast answers!
After reading this guide, I already ordered a new adapter and SSD.

But for testing until they arrived I checked my setup (adapter, HDD, Raspberry) with raspberry PI OS, and it’s booting perfectly fine with this adapter, HDD and firmware. I already updated the firmware.

Is hassos so different from raspberry pi OS?

I have the same problem.
Raspberry pi OS boots perfectly fine from a usb3 port with a StarTech adapter and a Patriot Burst SSD.
But when I flash Home Assistant OS on the ssd nothing happens. I tried with Version 5.10 and 5.11 from both the usb3 and usb2 ports.

Same problem here. I’ve tried the StarTech recommended in the earlier article and his previous recommendation before that. In both cases, I’m able to boot if I use Raspbian, but not HA OS. Is there any plans to make this more stable and reliable install for the HA OS?

Update, i got a generic usb3 sata adapter that reported JMicron, it did NOT finish boot up on 3.0 ports, it DID boot on the USB 2.0 ports, then i upgraded the firmware with the link provided by @m0wlheld and moved it back to the USB3 port . Seems to be working. Just takes a bit longer to boot i dont know why.

So i upgraded from 4GB 32Bit SD to 8G 64bit OS and SSD Just uploaded my snapshot and we are back in business. Thanks!