SSH: Connection refused

I’ve installed Home Assistant in a VM on my Synology. I installed the Terminal & SSH add-on. I can connect through the Terminal on de sidebar within HAos.
But when I fire up the Terminal on my Mac I get this error message:

Renzo@iMac ~ % ssh -v [email protected]
OpenSSH_8.6p1, LibreSSL 3.3.6
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 21: include /etc/ssh/ssh_config.d/* matched no files
debug1: /etc/ssh/ssh_config line 54: Applying options for *
debug1: Authenticator provider $SSH_SK_PROVIDER did not resolve; disabling
debug1: Connecting to [] port 22.
debug1: connect to address port 22: Connection refused
ssh: connect to host port 22: Connection refused
Renzo@iMac ~ %

Can anyone help me fix this? I’m not sure what’s going wrong.

Is that the IP of HA or of your Synology?

had the same … its disabled by default.
You need to go to the configuration section of the addon and choose if you want use ssh-keys or password authentication and activate port 22 in the network section.
after restart of the add on connection should be possible
You can control if the ssh service is running by typing ‘netstat -an’ in the web console
check for line:
" tcp 0 0 :::22 :::* LISTEN"
which shows that the scp server is running and listen on port22

1 Like