SSH not working and Z wave USB dongle

Dear all,

First of all happy new year!

I have two problems. After the crash of my Raspberry, SSD card did not work, I did a full new installation to Now I have two problems. The setup of SSH is not working trough the front end. When I install the SSH server in the app store and try to start it is not working and get 502 bad gateway.
When I install the SSH & Web terminal the same issue.

Also trying to get remote in the system via terminal server on my mac book

ssh [email protected]

is giving me

ssh: connect to host port 22: Connection refused

Second problem. The system did not setup the Z wave USB dongle. Normally I can do this via the terminal server to get the software. Also with a screen and keyboard on the pi is getting me stranded.

Help needed

The ssh server uses ‘root’ as the user. You have to either specify a password in the ssh add-on configuration or a ssh key.

If you installed with the default HassOS image, then you will not typically use the screen / keyboard.

The pi user doesn’t exist in any HassOS installation. root is used for ssh into HassIO add-ons, as well as HassOS.

What does this mean?

You don’t download software on HassOS/HassIO, and you shouldn’t need to do anything to get a ZWave stick to show up.

root is giving me the same issue. Did not set anything for pasword or something.

If I try to setup the zwave network I do not see the dongle. If I go to settings and zwave network I try to start the network but without any succes. I left the machine for one hour but nothing is visible.

So what happens when you go to the hassio menu and look at the system hardware?

If HassIO can’t even see the dongle, the zwave page on home assistant is utterly worthless.

  • serial:
    • /dev/ttyAMA0
    • /dev/ttyACM0
    • /dev/serial/by-id/usb-0658_0200-if00
  • input:
    • Dell Dell USB Entry Keyboard
    • Logitech USB Optical Mouse
  • disk:
    • /dev/mmcblk0p5
    • /dev/mmcblk0p3
    • /dev/mmcblk0p1
    • /dev/mmcblk0p4
    • /dev/mmcblk0
    • /dev/mmcblk0p7
    • /dev/mmcblk0p8
    • /dev/mmcblk0p2
    • /dev/mmcblk0p6
  • gpio:
    • gpiochip504
    • gpiochip0
  • audio:
    • 0:
      • name: bcm2835_alsa - bcm2835 ALSA
      • type: ALSA
      • devices:
        • [object Object]
        • [object Object]
        • [object Object]


It appears one of these devices is your ZWave controller

Yes but they are not visible in my zwave network. When I’m going to integrations -> zwave it is empty and no things are connected. The auto add is switched on.

Dongle is sorted. It is not the /dev/ttyAMA0 path but the /dev/ttyACM0 so the dongle works. Now the SSH part.

If it doesn’t start the SSH server, 502 bad gateway makes sense.

So what do the logs say?

20-01-01 20:06:00 INFO (MainThread) [hassio.homeassistant] Updated Home Assistant API token
20-01-01 20:08:41 INFO (SyncWorker_18) [hassio.docker.interface] Restart homeassistant/raspberrypi3-homeassistant
20-01-01 20:09:52 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
20-01-01 20:13:20 INFO (SyncWorker_3) [hassio.docker.interface] Restart homeassistant/raspberrypi3-homeassistant
20-01-01 20:14:06 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
20-01-01 20:40:37 ERROR (MainThread) [hassio.api.ingress] Ingress error: Cannot connect to host ssl:None [Connection refused]

Those are the logs from the SSH ADD-ON?

SSH and web terminal.

Do I need to do something with this?

  "ssh": {
    "username": "hassio",
    "password": "",
    "authorized_keys": [],
    "sftp": false,
    "compatibility_mode": false,
    "allow_agent_forwarding": false,
    "allow_remote_port_forwarding": false,
    "allow_tcp_forwarding": false
  "zsh": true,
  "share_sessions": false,
  "packages": [],
  "init_commands": []

this is mentioned in the config.

Oh and here is a logfile

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] permissions: applying…
[fix-attrs.d] permissions: exited 0.
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] executing… Add-on: SSH & Web Terminal
SSH & Web Terminal access to your Home Assistant instance

Add-on version: 7.0.1
You are running the latest version of this add-on.
System: HassOS 3.7 (armv7 / raspberrypi3)
Home Assistant version: 0.103.5
Supervisor version: 193

Please, share the above information when looking for help
or support in, e.g., GitHub, forums or the Discord chat.

[cont-init.d] exited 0.
[cont-init.d] executing…
[cont-init.d] exited 0.
[cont-init.d] executing…
[cont-init.d] exited 0.
[cont-init.d] executing…
[16:38:29] FATAL:
[16:38:29] FATAL: Configuration of this add-on is incomplete.
[16:38:29] FATAL:
[16:38:29] FATAL: Please be sure to set a least a SSH password
[16:38:29] FATAL: or at least one authorized key!
[16:38:29] FATAL:
[16:38:29] FATAL: You can configure this using the “ssh.password”
[16:38:29] FATAL: or the “ssh.authorized_keys” option in the
[16:38:29] FATAL: add-on configuration.
[16:38:29] FATAL:
[cont-init.d] exited 1.
[cont-finish.d] executing container finish scripts…
[cont-finish.d] executing…

            Oops! Something went wrong.

We are so sorry, but something went terribly wrong when
starting or running this add-on.

Be sure to check the log above, line by line, for hints.

[cont-finish.d] exited 0.
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

yes. You need to either set the password or the authorized keys. This will be the password you use to log in with ssh.

Okay, but I did not set anything so what can I do? I’m using this the first time.

Set a password or give it your SSH key…

How can I set a password?

Type a password in the config page???