SSH port is disabled. Prevent start of SSH server


Suddenly I found that I cannot connect to HA using putty. The message tells me that connection is refused. It used to work but I do not remember when was the last time I used it.

When I restart HA or just restart “Terminal & SSH” Add-On, I see the following:

[10:05:45] INFO: Starting Web Terminal...
[2020/06/20 10:05:45:1610] N: ttyd 1.6.0-c15cfb7 (libwebsockets 3.2.2)
[2020/06/20 10:05:45:1611] N: tty configuration:
[2020/06/20 10:05:45:1611] N:   start command: tmux -u new -A -s homeassistant bash -l
[2020/06/20 10:05:45:1613] N:   close signal: SIGHUP (1)
[2020/06/20 10:05:45:1613] N:   terminal type: xterm-256color
[2020/06/20 10:05:45:1976] N:  Using foreign event loop...
[2020/06/20 10:05:45:1984] N:  Listening on port: 8099
[10:05:45] WARNING: SSH port is disabled. Prevent start of SSH server.

This is the configuration for my “Terminal & SSH” Add-On. Can someone help me?

authorized_keys: []
password: MyPasswordIsHere
  tcp_forwarding: false
port: 22

I don’t think you can add the port in the configuration. You have to enter it separate.


Then it won’t start completely

1 Like

It worked for me. Thank you for your help.

don’t work for me also with the last stable homeAssistant.
I configure the ssh key with the tutorial from:

From Putty, I have the following msg :

2020-12-08 19:21:16	Looking up host "" for SSH connection
2020-12-08 19:21:16	Connecting to port 22
2020-12-08 19:21:16	We claim version: SSH-2.0-PuTTY_Release_0.73
2020-12-08 19:21:18	Failed to connect to Network error: Connection refused
2020-12-08 19:21:18	Network error: Connection refused

I moved from a synology Virtual Machine manager to Raspberry PI 4 supervised.
make a backup and restore it to the new install on de Pi all dashboards are working wel !!

the terminal works perfect on the synology I see in the log “INFO: Service restart after closing”
but not on the Pi I only need a terminal in HA not SSH

wat goes wrong here ?

Solved !!

Back to Clean install, then restore HAform backup but NOT the Add-on’s Terminal SSH & File editor.
Every thing ok, then install the two add-ons’s (with the correct arch X64 vs Arm that’s it !!

How did you pick the x64 arch when installing the add on? I tried a restore to move my system from a Pi to a x86 system and all the addons failed but I can’t seem to get the proper arch versions installed. When I uninstall and then reinstall they still don’t start.

1 Like