SSL Certificate Sensor Issue


I am using the SSL sensor on the components page to check how many days my certificate has left to expire.

This was working when I first put it in, I havent made any changes since then and only done a couple of server reboots. The sensor now only displays “Unknown Days” as the result.

I have seen some people say it can take up to 12 hours to refresh but I’ve left my server running for over a week without a reboot and nothings changed.

Any ideas on this one? I cant work out why… Ive tried removing the sensor and re adding it, giving it a different alias etc

Probably need to at least post some configuration files to see if there is anything there.

Have you looked in the home-assistant.log in your homeassistant directory to see if there is anything there?

My sensor:

- platform: cert_expiry
  name: SSL cert expiry

Ive had a look in my logs but cant find anything that would help me with this


That seems to have solved it!

Odd…it was working before and i’ve had to put a www. to get it working again.

Thank you!