SSL Connection Issues


I’ve been having connection issues when not connected to the same network.

I’m using Duck DNS and Nginx.

I’m not sure what’s changed as it used to work, but when I’m on ANY WiFi network I can connect remotely but if I go on my phone via 4g I get the error message below. Any ideas?

I have a VPN on my phone but the app is set to bypass the VPN so it shouldn’t be that. I’m more confused as I can connect when on another person’s WiFi!!!?!?!


Your ISPs probably have blocked the DuckDNS domain, because some evil-doer have used that domain for something nasty.
Many ISPs have malware filters and some of them are not managed that well, so they just block the entire domain without looking at the usage of the domain.
The fun part is that some of the recent cases have been UK-based ISPs, like O2, and UK themself have an extra layer in the domain hierachi (, so if international ISPs did the same, then the entire would be blocked.

Try to connect to your URL from a browser with just http:// in front, instead of https://
My bet is that you get a page from your ISP telling you that it has blocked your connection.

In the number of times I’ve almost locked myself out of HA, I’ve seen something like that and I’m on a branch of 02.

Wonder if putting it through the VPN will fix it

It has been the duckDNS domain that have been the problem before, because that is what the ISP block on.
Best option would be getting your own domain, so noone can misuse it.
Second option would be switching to another DynamicDNS provider, but the same could then happen there. DuckDNS is just the biggest one and therefore more exposed.

Yeah @WallyR that works. I always bypassed my VPN for speed reasons but it works when I go through VPn so thanks.

If you have VPN, then why use the much less secure solution of a port forward???

Any ideas how I can clget Nginx working right?

I’m unable to get my konnected to work with Nginx…

Because I don’t know how to do anything else?!?!?!

Do you have a need for NGinX?

VPN is by far the most secure solution and since all runs locally from HAs view, then also the simplest.
NGinX can be required for some external connection though, like Google or Alexa Assistants.

Yeah I have a Konnected alarm system that can’t handle ssl.

If I don’t have Nginx it doesn’t see the detectors.

Ok, NGinX and portforward makes sense then.
Try to maybe find another DynDNS provider.