Ssl error for telegram suddenly

Somehow during the last few hours, telegram has stopped functioning for messages sourcing from HA.
error is

Error sending message: Unknown error in HTTP implementation: SSLCertVerificationError(1, "[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: Hostname mismatch, certificate is not valid for ''. (_ssl.c:1000)")

which seems pretty obvious, but validating the domain in a browser does pose a valid certificate and it has not been renewed recently.
Also, i use bot from other application which is still functioning.

currently i dont get it and not sure where to look for start to fix now. Anyone ideas?

1 Like

Same here, I have several errors since today. Telegram messages stopped working.

I am in Spain.

for the sake of Geo location issues, where are you located? I’m in NL

Same here.

I’m located in Germany

Same Problem here (Luxemburg) 10 AM

same probleme from France.
start yesterday

thats interesting. Mine worked ok until this morning until around 10AM

10AM me too…

same here (Germany), last time it worked was yesterday 19:53 CEST, now it doesn’t.

Same here (Czech republic)

I found that my AdGuard is blocking

After unblocking it telegram seems to work again.

Seems that has been added in the adults list…

Nice spotted, will check that too. However the other app that uses telegram bot still sends messages. It might not go through add guard indeed that one.

i can ping just fine from my network

what is “the one” and what is “the other”?

After unblocking I do not have any more errors in the logs and messages are sent without any problems.

Check also if you have any dns server ip that automatically filters urls like cloudflare families dns, maybe they are using same ip spam lists.

One is ha. Other is octobot
Ha runs in vm. Octo in docker

Same here. Panama
Is this normal?

Here the same error:

Me too, works now

No, I have the same error if I do not allow it in adguard.

Now it it is working, the certificate was fixed