I’ve got a RPi 3 running HA for the last few months. It’s been fine, until yesterday. There were two upgrade packages showing ready, so I installed them.

Now when I try to connect I get the error SSL_ERROR_RX_RECORD_TOO_LONG. ( Firefox 125.0.3 )

“An error occurred during a connection to homeassistant.local:8123. SSL received a record that exceeded the maximum permissible length.”

The RPi is located in an awkward place, it’s difficult to get to, but I can power-cycle it. Is there anything I can do without physically accessing the RPi ?



Whats your installation method? Any components in the infra in front of HA?
Tried different browser too?

I just tried Edge. It asked for user and password for homeassistant. I couldn’t remember, so went back to Firefox to get them. Before locating password store in Firefox I refreshed the homeassistant tab, and it sprung into life !.

Maybe the ‘kick’ from Edge reset something in HA.

Whatever, it’s working now !.



I am getting the same. Just used Raspberry Pi Imager to install a fresh HA image. Booted up RPi and it says it’s running Home Assistant OS 12.4 with two URLs I can use.

Now if I visit https://homeassistant.local:8123/ on Firefox and got the same error with Error code: SSL_ERROR_RX_RECORD_TOO_LONG.

Doing the same on Safari I got “Safari can’t open the page “https://homeassistant.local:8123/” because Safari can’t establish a secure connection to the server “homeassistant.local”.”

I do not have another browser I can try further.

use http , not https

Oh I see. Thank you!

The tutorial at Raspberry Pi - Home Assistant is outdated.

It says:

In the browser of your desktop system, enter homeassistant.local:8123.

If you are running an older Windows version or have a stricter network configuration, you might need to access Home Assistant at homeassistant:8123 or http://X.X.X.X:8123 (replace X.X.X.X with your Raspberry Pi’s IP address).

Nowadays all browsers default to https, so by typing just a hostname and a port, the browser will fill in https:// for me.

Once I have used http for the first time, my browsers do remember that port 8123 is http, and from then onward I can type just homeassistant.local:8123 but not the first time.

1 Like

That’s true, and lots of new users fall into this “pithole” :slight_smile: , and not everyone is very familiar/comfortable with how browsers work, or with “troubleshooting” when such a “unknown error” occur, so as you say it seems like the Documentation could be better on this point.

The good thing is, when you use more time in the forum, and get more familiar, you can actually “Request” to Edit/improve most of the Documentation :grin:

Im glad to hear that it was actually only this problem you experienced :+1:, as many other first-time users runs into “a wall” of access-issues, which can take days, and/or even reinstall attempts to solve.

Welcome to the Forum, and enjoy your addictive new “world” with Homeassistant