SSL, Front End, expired SSL certificate, and Dehydrated

Quick question. Getting SSL set up was one of the 1st things I did with my HA install, and honestly it’s just been working and I’ve forgotten/neglected it. Anyway, found my front end was not accessible today, and it looks like my SSL cert has expired.

So, I believe I set my ssl cert up following this tutorial

but maybe I never set up the cron job, or its been erroring and I did not noticed. Either way, I just want to make sure I fully understand what I need to do.

If I just activate my VENV and run the following command, will that fix everything?

dehydrated -c

Or do I need to go through the whole process again, since it expired.

You need to navigate to the folder where that script is stored. I don’t believe you have to activate the VENV. I have run splitbrains setup with and without activating it, both work.

But once in that folder, do I just need to run

dehydrated -c

assuming everything else has not changed


(meeting post limit)

1 Like

Ugg, So,
dehydrated -c did not work. I tried as HA user and root,

deleted and reinstalled dehydrated, followed steps and ended up with this error

ERROR: domains.txt not found and --domain not given

It’s definitely there. I’m in the dehydrated directory

Any tips?

I feel like I’ve totally screwed this up.

When I first tried to renew, I got an error saying dehydrated was not installed and to do an
apt install dehydrated

which I did

But now I see my errors are path related

INFO: Using main config file /etc/dehydrated/config

ERROR: The path /etc/dehydrated/conf.d specified for CONFIG_D does not point to a directory.

I’ve removed dehydtated with an
apt remove dehydrated

I’ve reinstalled, removed the home/homeassitant/dehydrated folder, and tried to start over, it seems as if it keeps expecting me to be the the /etc folder, I even put my domains.txt in the folder

I’ve opened port 80, 8123, 443, on my router, closed them back. Overall I feel lost. I do remember this was confusing when I 1st did it months ago, because there were so many ways to do this, and the methods were different depending on if it was, etc

I’m runninging in a python venv. Also I’ve tried this as root, as homeassistant, I’ve set permissions to 777 on folders, and files, overall at this point I have no ssl , but at least I can access the front end for a bit.

If anyone can help me get this straight, I’d really appreciate it. I’m sure its more of an OS/config issue vs HA, but any help is appreciated

I’m also having problems after the SSL certificate got renewed. Anyone a good walk through to get unstuck again?

For me the trick was to make sure I ran the dehydrated app from the python venv

1 Like

@ptdalen thx for the tip! It seems I indeed ran the dehydrated script with the wrong user. Everything working fine again now!

1 Like