Ssl location ha os

I’ve put my certs in /usr/local/ but putting corresponding entries in configuration.yaml won’t find them.

Is this some docker thing, so that the path I see in terminal isn’t the path that’s seen when ha os is loading (or trying to) the certs?

The permissions are ok so…?

BTW I did find a guide (well several) but stuff like su -l homeassistant doesn’t work for me, so probably a different platform - I get that this is the complication here…

You should put your certs in /ssl, which is available by default and is mounted into the HA container. You can also put them in any of the other default mounted directories (such as /config), but /ssl is typical, and there’s where, for instance, the Let’s Encrypt addon puts them.

Thanks - I also had an issue whereby it doesn’t seem to like the filenames created by wildcard certs. So I had to rename my files that were * to just I did try escaping the asterisks to no avail.

Can you help me too?
I have the same problem: I tried to create ssl for Vaultwarden add-on using Nginx Proxy Manager add-on. I’ve download them and placed them in /ssl folder in /config but HA doesn’t recognize them.

Another case: I tried to connect Google Assistant to my HA. I did everything in the Google Cloud and place the SERVICE_ACCOUNT.json file in /config (where the configuration.yaml). As above, my HA don’t find/recognize the file.

A screenshot of my file library:

I’m running HAOS.