Stability - Raspberry Pi


#1

I think I am now on my forth rebuild, though I am beginning to lose count. The latest installation was functional for almost a week. I’m on my third SD card now.

Has anyone here experienced stability issues and has been able to overcome them? Does the PI require better ventilation. I like HA, it’s a great concept, but it’s of little value if it requires re-installation every second week.

It has become a time sink, with little return. Is it time to give up on this?


#2

What type of sad-card are you using? Ideally use one suitable for a webcam… I use a Samsung EVO but there are better high endurance cards available. Also what power supply (amp rating) do you use? Must be minimum 2.5amp for a Pi3


#3

My personal experience its been rock solid for months with pi 3 and pi 3+. You may have a faulty sd card, unreliable power supply or even a bad pi3.


#4

That would be three faulty SD cards then?


#5

The current SD card is a Verbatim 32g Premium. It’s a brand new raspberry pi, with official power supply. It’s great for a hobby, but simply not reliable enough by my experience. This time it went of the network and won’t even boot.


#6

I use an U1 SD card and I haven’t ever had problem with it.
I use the original power supply too.
I had problem with WiFi connection which lost 25% of packets but since I passed to wired connection my Pi haven’t had any problem.
I mounted my Pis in an open case like this:


I also use docker containers to run my images of HA, mosquitto, zigbee2mqtt and node-RED.
That is my experience :sweat_smile: hope could be useful.


#7

Yeah, I just don’t see how I can rely on such an unstable system. Think it’s time to give this a miss and look for other options.


#8

I’m on wired ethernet as well.


#9

Ops I forgot to say that I use the Raspbian stretch lite O.S. and upgraded the Pi to latest firmware (just in case).


#10

Are you always using the same kind of SD-Card? I never had a problem once I switched to a Samsung EVO but had similar crashes before that.

It’s not home assistant - it’s either the SD-Card or the power supply. 99% of Pi issues come down to one or both of those.


#11

My Pi 3B has been running for 10 months without issue (other than self made issues).

I use a Samsung EVO card and a power supply capable of delivering over 2.5A. I also use a metal heatsink case for the pi.

The Pi can be a very stable platform.

If you really do want to try something else this is an easy option:


#12

My Pi 3 has been rock solid since I started using HA back in May 2017. I’m using a 32GB Sandisk Ultra SD card and the official Pi Power Supply. I have not had any issues with the Pi or HA in that time.

I’ve rebuilt HA once, and that wasn’t even really a rebuild, I just cloned the SD card to a bigger one and started my HA setup from scratch (just my config files, not HA itself).

The other possibility is that you may have a faulty Pi. Have you tried the SD cards in something else? Like your PC to see if the still work? Maybe even the power supply might have issues. I wouldn’t just give up yet.

Maybe install this custom component and see what it says about your power supply. I’m not sure what HA install you are using (hass.io, hassos, hasbian, etc). I’m not sure if this works with HASS.io yet


#13

I have two Pis using the SanDisk Ultra SD’s. My MQTT broker has run for months and I only had to restart it when the Ethernet switch failed. My Home Assistant Pi is likewise remarkably reliable. It runs for weeks at a time, but often a hardware or wiring change necessitates a restart.

I power both of them with this:

I simply don’t trust wall-warts to deliver their rated power.

Sig


#14

That doesn’t actually prove anything. The card I had that was crashing even passed a hardware test in my Win10 PC but it was still a dud for Home Assistant.


#15

I completely agree. I found the RPi ‘supplied’ one was fine but I also have a 3A one I use with a different Pi too. It also depends a bit on how much hardware you plug into it. I just find it’s a problem going with the minimum spec.


#16

@DavidFW1960 fair enough. I’ve learnt something new. I don’t use SD cards for very much. Actually, my HA setup is the only one.

But from previous experiences with drive issues, I’ve always tried them in other devices to verify the issues, for example, the old mechanical HDD’s.


#17

Yeah I was pretty surprised myself. I replaced the SD-Card and then did the hardware test on my WinPC on the card and it passed with flying colours. In the Pi, HA was becoming unresponsive every 24 hours with that card. Strange to say the least. Once I switched to the Samsung EVO, it was stable for months.


#18

Come to think of it, I do have a Raspberry Pi Zero on an “official” wall-wart that has a camera on it watching my office. I need to reboot it frequently. I will move it to where the Aukey supply is located to see if it becomes more stable.

Sig


#19

If one SD card fails then there are a number of possible causes.

If multiple good quality cards fail the tendency is to think power supply.


#20

I have no experience with pi’s but I’m running hassio within docker in a virtual ubuntu hosted by Windows datacenter server.
Maybe you can do something similar?
I’v never had and issues other than out of disk space.