Stale entries in Core log when read from the Supervisor

Hello everyone. So i got this annoying thing when i open up Home Assistant, go to Supervisor → System and then select “Core” for Log Provider.
I receive a BUNCH of these lines (and doesn’t even have timestamp):

/usr/local/lib/python3.8/site-packages/urllib3/ InsecureRequestWarning: Unverified HTTPS request is being made to host ‘domain.sth’. Adding certificate verification is strongly advised. See: Advanced Usage - urllib3 2.2.1 documentation

I know this is a stale entry since I’ve had this issue before and actually i issued a letsencrypt certificate for that domain so it will actually read a good certificate ! When i open from my pc, phone, laptop it reads as a valid certificate. Also, the entry above, is NOT displayed in home-assistant.log file. So i have no idea where it is reading it from but i cannot see the log file content in supervisor.

I have also tried removing (or truncating, don’t know what) the log file, still the same.
Any help on clearing this from supervisor ?

Yeah, forgot to mention.
Supervisor Version: 2020.11.0
OS: HassOS 4.17
Home Assistant Version: 0.118.0
Hardware: Raspberry Pi 3B+