State and trigger node acting on their own


I’m trying to build some conditional automations that consist of multiple inputs. I first tried to build logic gates, but got the advice to try string together each condition into a path.

So basically I’m waiting for an input bool that calls my “night” routine. Then my PC shuts down with the help of hass workstation then it checks if the pc is really off before switching off the power to the PC.

This kind of works already, however the trigger states acts on its own and doesn’t wait until it gets called by the 90s delay.
I tried with an events state node but that doesn’t have an input so I would need to build a logic gate again.

I noticed similar behavior with big time whereby I enable input on a big timer node but it acts on its own again not waiting to get called by the input.

Is there a way to force the node to wait to be called by a previous node or should I check out how to build logic gates?

Cheers F.

If you just want to check the state of an entity try the current state node

I wouldn’t have a 90 seconds fixed delay to cut power on a computer.
What if there is an update installing as your computer is turning off?

Ill added some comments. @Hellis81 yes you are right. After the 90 secs is another check “trigger state sensor dummy” that makes sure the pc is really off. This works

The issue is that it always works. I want the dummy sensor only working (or only being checked) when it’s part of the whole chain that came before.
There are other situations where the PC is off but I don’t want the pc switch to turn off, because e.g. my sound system is also powered by the same switch.

The only alternative I see is creating a logic gate that checks if the sleepmode is on AND the PC is off. But I wonder why the trigger state node even has an input, if it still reacts independently of whether it was called or not.

These are not inputs, these are more akin to a switch. They can enabled or disabled the node. It will not work for you here. As mentioned before use a current state node in liu of the trigger node.

I see, but how do i limit a state node to only react to the state change in the context of the sleep routine?

Use the same settings that you have in the trigger node.