State of Fibaro lights (on/off) not correctly displayed


I add my Fibaro HC2 to using the Fibaro component and all my Z-Wave devices are available in

However, the state of my lights (on/off) are not being correctly displayed in the front end.

For example, I will turn on a light on front end and the status would move from left to right (to indicate ON and this turns on my lights) but then will quickly move to the left (OFF position) in - when in fact the lights are not OFF

I really don’t understand why. Is there a way to have always show the current state of my Fibaro devices?


My Fibaro power socket has the same behaviour. You probably need to poll them by setting polling_interval for the Z-Wave controller and then polling_intensity for the light entities. Or maybe setting delay for lights would work. See It is something to do with manufacturers not implementing the hail command class (something like that), I believe.

Is hail a typo?

No. COMMAND_CLASS_HAIL is a thing. I just checked. (It’s still not necessarily relevant to the question though.)

First question is if the status is updated in HC, is it? I have this same issue with some older zwave devices that just lost their instant status updates (lifeline to controller) over the years… very odd… (btw I have this in Vera and not in Fibaro HC.

Yup, devices within HC are updating their status correctly. I tried the polling idea but still nothing has changed.