State of renamed Nordpool sensor unknown

I have used the Nordpool integration for a few weeks, and it has worked liked a charm. However, all of a sudden after a HA reload the sensor state just returns ‘unknown’. My APEX chart just keeps telling me ‘Loading’ and nothing works. I haven’t made any changes related to this sensor.

I renamed the sensor to sensor.nordpool to make my YAML code dependant och region etc almost immediatly after I made my first configuration. Checking the sensors with the states tab on the Developer page revealed the original name is back again!

So my question is if it is unsafe to rename this sensor? The Nordpool README file recommends renaming…

You have to rename it in the nordpool setup.
It is auto-generated at each start of the integration.

You meen in configuration.yaml? I tried to add a name label in the definition where I have added a few other specific things like VAT, but name is not allowed. The README does not provide any help on this subject. Do I need to create a template sensor with a new name?

Your reconfigured sensor should have a new name and you probably need to use that auto-generated one.