Stelpro Maestro thermostats

Has anyone been able to get these thermostats to report the temperature and control them from Home Assistant?

I was only able to get the reading from the humidity sensor. :frowning:

Same deal here, just added a couple of the slave Maestro thermostats to my HASS server, I can see them as zigbee devices and I can see the humidity readings but nothing else.

I think the issue is that HASS does not currently have a generic ‘ZHA Thermostat’ device like it does for Z-Wave, hopefully that is something they will be able to support in future!

can you elaborate a little ?
what exact device do you have ? (is it a smt402? )
how did you get the humidity sensor ?
do you use zha or zigbee2mqtt or something else ?

Hi bobzer,

Yes it’s the SMT402 which they call the Stelpro Maestro. Normally, you get a master device (black) and a few slaves (white) that communicate together and the master device provides a web interface. The slaves can also use Zigbee only to reach a smart hub, which I am doing with Home Assistant. I think you knew that already though. :wink:

I use “zha” and I managed to connect the 2 thermostats that I have, but only the humidity sensors are detected.

I think it might have something to do with the fact that “zha” does not have a thermostat device type yet?

This is what I see in my entities :

zha.zha_stelpro_maestrostat_… (online)
nwk: 0x8f61
ieee: f8:f0:05:ff:ff:…
lqi: 255
rssi: -70
friendly_name: Stelpro MaestroStat

zha.zha_stelpro_maestrostat_…
nwk: 0x476c
ieee: f8:f0:05:ff:ff:…
lqi: 255
rssi: -71
friendly_name: Stelpro MaestroStat

sensor.stelpro_maestrostat_…
unit_of_measurement: %
friendly_name: Garage Humidity
device_class: humidity

sensor.stelpro_maestrostat_…
unit_of_measurement: %
friendly_name: Gym Humidity
device_class: humidity

So the thermostats are there, but only the humidity sensors show up and not the temperature sensors or a climate entity.

Thanks for any help you can provide. I am still a newb with this! :wink:

Hi Folks,

I have a Stelpro STZB402+ installed in my garage and I’ve been able to pair with it using the Homeassistant ZHA component for the last couple of months. I use the Nortek HUSBZB-1 usb to Zigbee/Zwave stick. Additionally with the last release 0.88.2 under configuration->Nodes it shows up as a Node and I can then choose a Cluster. One of the Cluster options is ‘Thermstat’ and from there I can get and set the ‘occupied_heating_setpoint’ which reads the current thermostat setting and allows me to set this value as well. The value for me is in Celsius so if I read this temperature and get 800 this equates to a setting of 8 degrees C on the unit. I have not had time to experiment much more with this integration or try any automatons with it.

Thanks rgill!

I can finally get some thermostat functions to work between the Stelpro Maestro and Home Assistant! :slight_smile:

As per your instructions, from the ZHA configuration, I can now get the current temp reading, temp setting and change the temp setting! Now I just need to figure out how to put this in the graphical interface.

I’m not sure if this would be of any use, but here’s a list of the attributes that I can get a value from and their current output :

abs_max_cool_setpoint_limit (id: 0x0006) = 4000
abs_max_heat_setpoint_limit (id: 0x0004) = 3000
abs_min_cool_setpoint_limit (id: 0x0005) = 700
abs_min_heat_setpoint_limit (id: 0x0003) = 500
ctrl_seqe_of_oper (id: 0x001b) = 2
local_temp (id: 0x0000) = 1350
local_temperature_calibration (id:0x0010) = 0
max_cool_setpoint_limit (id: 0x0018) = 4000
max_heat_setpoint_limit (id: 0x0016) = 3000
min_cool_setpoint_limit (id: 0x0017) = 700
min_heat_setpoint_limit (id: 0x0015) = 500
min_setpoint_dead_band (id: 0x0019) = 25
occupancy (id: 0x0002) = 1
occupied_cooling_setpoint (id: 0x0011) = 3500
occupied_heating_setpoint (id: 0x0012) = 1400
outdoor_temp (id: 0x0001) = -32768
pi_heating_demand (id: 0x0008) = 100
remote_sensing (id: 0x001a) = 2
system_mode (id: 0x001c) = 4
system_type_config (id: 0x0009) = 0
unoccupied_cooling_setpoint (id: 0x0013) = 4000
unoccupied_heating_setpoint (id: 0x0014) = 1700

  • As rgill mentionned, the “local_temp” attribute matches the current temperature reading on the physical unit. Also, the “occupied_heating_setpoint” matches the current setting of 14.0C.
    ** The “pi_heating_demand” goes up to 100 when the heating is active.

It would be nice to have a script that reads all the attributes and dumps the output automatically.

1 Like

Hi
sorry to bring back an old post but did you manage to use the information in home assistant?
I would like to use the info with node red. did you create a sensor or something else?
Thank you

I used to do a little bit of programming, but not much and it was so long ago that it feels like it was in another life!
I was hoping that someone would be able to help us out from what I posted actually. :wink:

you wrote some script to use the data from stelpro ?

If you interested, I just added the support for Stelpro Maestro into Zigbee2Mqtt: https://github.com/Koenkk/zigbee2mqtt/pull/2628

1 Like

Great news for Stelpro Maestro thermostat users!

I noticed yesterday that the ZigBee integration now supports the thermostat properly for both humidity and temperature! I do not know in which version it started working, but thanks a lot to everyone who contributed to add support for this! :slight_smile:

@jsimon

Woa, great timing. these are the last two devices I have on my Smartthings system and I was hesitant to move them over.

Hi guys, can you please shortly describe you way and you guid how to connect Stelpro Wallet thermostat? Thanks guys!