Still issues after updating HA and Protect

Hi all,

I have read a lot about the release of Unifi Protect 3 and how it stopped working in Home Assistant. Sadly I had already updated my Protect to version 3 when it was the official release. At that time I didn’t updated my HA to 2024.3.2. After I discovered that the Unifi Protect integration stopped working I immediately updated my HA to 2024.3.2. But that didn’t solve the issue.

Then I removed the the Unifi Protect integration and re-installed it. But that didn’t solve it.
Yesterday I installed HA 2024.4.0 and after that I re-installed the Protect integration again. The integration is up and running but not with the correct entities I used before. Now I’m unable to get the image preview of the camera.
I was using the entity camera.oprit_high
I now have an entity like camera.oprit_high_resolution_channel
but that doens’t give me the preview. It only shows a live view when I click on it. On my dashboard I get a grey image with some kind of logo.

How can I solve it to get it working like it was before all the updates.

Home Assistant

  • Core 2024.4.0
  • Supervisor 2024.03.1
  • Operating System 12.1
  • Frontend 20240403.1

Unifi Protect on UNVR
Unifi OS 3.2.12
Unifi Protect 3.0.26 (updated today to this new release of version 3 in the hope it solved it)

Thank you in advance, also from my wife :wink:

Schermafbeelding 2024-04-05 om 09.24.47

1 Like

Thank you for your reply.

I already enabled the “preload”, but makes no difference.

I removed the integration because I was finding a way to get it working again. For me it’s not an issue that the naming of the entities is changed. But main issue is that when I add a camera to a dashboard by using the Picture entity Card I don’t get the preview image.

When I select Live in the camera view section I get a live image of the selected camera. But when I choose Auto I get the gray image. Previously when I choose “Auto” I got a preview of the camera view that updated every ±10 seconds. That was good enough for me. When I choose “Live” for the multiple camera’s I have added to the dashboard the loading takes too long.

Also when I go the Protect integration and select one of the camera’s, I previously saw a little camera view image near sensor (of the recording camera entity) but that is also blank.

Is there a way to get the “Auto” camera view working again?

Schermafbeelding 2024-04-05 om 19.47.15

THANK YOU!!! (for the trick to change Auto → Live so my camera view card would work again!)

1 Like