Stop HA trying to connect to a device

I am continually getting these errors as HA trys to connect to a device that is switched off.

How can I stop it doing this?

2019-12-21 09:32:50 INFO (MainThread) [homeassistant.components.esphome] Can't connect to ESPHome API for esp32_ble.local: Error resolving IP address: [Errno -2] Name does not resolve
2019-12-21 09:32:50 INFO (MainThread) [homeassistant.components.esphome] Trying to reconnect in 60 seconds
2019-12-21 09:33:02 INFO (MainThread) [homeassistant.components.esphome] Can't connect to ESPHome API for Error connecting to ('', 6053): [Errno 113] Connect call failed ('', 6053)
2019-12-21 09:33:02 INFO (MainThread) [homeassistant.components.esphome] Trying to reconnect in 60 seconds

I have been into Configuration / Devices and disabled the sensors (why is there not a slider to disable all of them at once?) to no effect.

I cannot see any other facility to tell HA to ignore a device it has previously discovered.

Why not disable it ?


Where is that dialogue?

Configuration -> Entities -> Click on the entity you want to disable.

The entities are not showing up there. I’ve disabled them in the Configuration -> devices but HA is still looking for the device.

What is odd, is that it is only certain devices this happens to. I have other devices, that are exactly the same, but HA does not continually try and connect to them.

You may need to edit the core.entity_registry file which is in the ‘.storage’ folder

AFTER backing it up.

You are kidding - there is not builtin mechanism to tell it to ignore a device…

So, what bad things can happen?

What exactly do I need to edit?

Or just ignore? What harm is it doing?

Ha, that’s not in my nature :laughing:

Also it fills the logs up with a huge amount of guff masking other things that may not be right.

There is a hidden .storage folder within your config folder, but actually I think it’s better not to edit the files there.

I tried it today and the device re-appeared after restarting HA.

I’m now using a firewall in order to block some devices from accessing HA, I like to block my chromecasts for example.

I’d much rather HA had a built in device blocker, I don’t want HA to control something unless I want it to!

1 Like