Strange Z-Wave sensors appearing

I have few times seen strange sensors appearing to my HA installation. Latest are “Aeotec DSB05 Multisensor Dew Point” and “FIBARO System FGWPE/F Wall Plug Relative Humidity”, which does not make any sense. :slight_smile: And yes i do really have these multisensor and wallplug, but such sensors do not exist in these really, i think.

Any ideas why is this happening? So far i have just hidden these, but i’ve been thinking is there something wrong because this is happening?

Sound like this:

Yes looks like same problem. Strange, since it has now happened to Aeotec and Fibaro units. Have to wait and see if this continues.

Same here. Some of my Aeotec DSB05 multisensors are reporting Angle Position, Tide Level and CO2 levels - weird!

Strange yes. Hope this could be fixed in future releases.

Since you have same sensors, do they work ok? Mine has problems to reset state when motion is sensed. Like when there is really movement, they report ok, but they stuck to that position like there is movement all the time. So far couldn’t find solution for that.

The motion sensors work fine as I use several to control lights. The temperature sensors tend to report temperature around 1000 degrees if I restart HA but then settle done to nomal readings. I am planning on replacing them with the newer model if this can’t be sorted out.

I tried hiding the stray entities from HA but they kept reappearing. I eventually edited the zwcfg_xxxx.xml file and searching for each instance of DSB05. There should be three lines below the entry for the multisensor defining what sensor values it returns. I changed all mine to read:

<Value type="decimal" genre="user" instance="1" index="1" label="Temperature" units="C" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="21.2" />
<Value type="decimal" genre="user" instance="1" index="3" label="Luminance" units="lux" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="65" />
<Value type="decimal" genre="user" instance="1" index="5" label="Relative Humidity" units="%" read_only="true" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="50" />

and deleted any other stray entries. You will need to stop HA before editing the file and make sure to take a backup first. So far those readings haven’t come back.

I have so far hidden these through customize.yaml, like this:
hidden: true

But this is quite annoying. Now again two new sensor appeared, have to hide those and need reboot HA to really hide those.

Just a me too reply here. My Aeotec Multi Sensors now report tide level!

HA really need to find out what is happening here. How can we trust the Zwave components if entry that make no sense appear and disappear without explanation?

It would be very nice to find solution here yes. I have just now this appeared “FIBARO System FGMS001 Motion Sensor Direction”, which makes no sense. Have to hide and reboot. Quite annoying.

Two other Zwave component (also Aeotec) started reporting weird new entry… This is effectively annoying. However, searching on the web for this, I see that other solution has this issue (ISY for example has this issue starting a while back).

I don’t know if it’s solved or not in their case.

Today two more… Quite an issue really. :frowning:
FIBARO System FGMS001 Motion Sensor Barometric Pressure
FIBARO System FGMS001 Motion Sensor CO2 Level

How could we proceed with this bug?

I have this happening with my CT100 thermostat… from what I can tell, it’s not a bug in Home Assistant, it’s in OpenZWave. If it were in any way repeatable, I’d try and troubleshoot it, but it’s so random I’m not sure what I can find. It hasn’t been too much of a bother, just really weird. If I find anything I’ll definitely share what I find.

I wonder if this is the same problem I am having in this thread…