Stream component hangups when accessing stream


I configured my HIK Vision DS-2CD2442FWD-IW like this:

- platform: generic
  name: test
  verify_ssl: false
#  framerate: 20  ## tried to limit the framerate as well
  still_image_url: "http://admin:[email protected]/ISAPI/Streaming/channels/101/picture"
  stream_source: "rtsp://admin:[email protected]:554"

And on the frontend like:

camera_image: camera.test
  - switch.door_open
title: Living test
type: picture-glance

But when I access the camera in chrome on my mac, or on my iphone or ipad in the Home assistant frontend, home assistant starts to stream, I do have picture for ˜10 seconds, but after that Home Assistant crashes (or slows down extremely) without any log entry.

I’m running in Docker on a Proxmox virtual machine, ubuntu 18.04.

If I use the stream service, I get picture on my TV (Nvidia Shield Android TV) as well, but only for about 15-20 seconds, HA slows down, but does not crash.

Anybody having similar issues?

what hardware are you running home assistant on? Did you try to lower the stream quality to see if that helps? I found that if the first stream dies, the second stream will be much more stable as well.

The hardware is a Intel I5 with 16GB RAM.

Tried with on my setup, and I’m facing the same problem with my DS-2CD2055FWD-I.

Error log:
2019-03-25 15:42:17 ERROR (stream_worker) [libav.h264] error while decoding MB 172 43, bytestream -9

It looks like it’s not able to decode h264.

Similar issue here. Cameras won’t view from browser UI, but I can send streams to chromecast devices. Sending streams to chromecast devices makes the UI hang eventually with no errors.

I get the following errors when trying to view a camera from the UI. I’m using Amcrest cameras. Tried the amcrest component as well as generic camera. Same results.

2019-03-25 13:29:42 ERROR (MainThread) [frontend.js.es5.201903210] Uncaught TypeError: Cannot read property ‘isOff’ of undefined
2019-03-25 13:30:42 ERROR (MainThread) [frontend.js.es5.201903210] blob: Uncaught ReferenceError: s is not defined

Check this comment it should fix the issue for you:

Thanks, but didn’t fix it for me. :frowning:

Even with the update to 0.90.2 I’m still having this issue. Anyone else?

Yup, still the same issues on in docker on ubuntu 18.04, using serveral hikvision cameras. Accessing the stream shows a moving picture but causes HA to crash after approx. 5 seconds.

Nothing in the logs, HA restarts after a few minutes leaving all automations disabled.

Now I did notice an error in the logs:

2019-04-03 20:22:47 ERROR (MainThread) [frontend.js.latest.201903210] https://myip:40443/lovelace/cameras_view:0:0 ResizeObserver loop limit exceeded

The issue is fixed for me after upgrading to 0.91 :slight_smile:

1 Like

Same here. Thanks for the update.

I’m on 0.95.4 and I still have the issue, anyone else?

i am facing the same issues… When i run it on a raspberry pi, its working fine…

I run HA on a Intel Pentium with Docker. which is causing the problems for some reaons.

Same for me unfortunately on a synology. HA in docker is fine on same machine.