Stream to Chromecast in .110?

I had just begun to work with Cast and want to stream some cameras to a TV Chromecast. I had gotten the below to work and display the camera in Developer Tools on .109.

Today, I upgraded to .110.2 and tried creating automations and now it does not work. It changes to the Chromecast, starts to show a playbar at the bottom of the screen, but then stops with just the Chromecast icon in the center of the screen. This is even doing the same call that worked on .109 via Dev Tools.

  - service: camera.play_stream
      media_player: media_player.living_room_tv_chromecast
      entity_id: camera.carport

Has something about .110 broken this? I also changed back to using default config during the upgrade (as I had previously removed discovery to prevent repeated device detection, now that they can be ignored), but I assume it should have everything necessary for this to work?

Nobody can say if this works for them in 110?

I finally figured this out. It was broken by the internal_url/external_url update. When I upgraded to .110, I was prompted to enter these settings and I did. But I finally noticed when I go into the configuration UI, these are disabled because SOME of that information is in my YAML (but not those two properties). So apparently it didn’t save to .storage, or else it did but isn’t getting read because of some of it being in YAML.

Anyway, I added these to the YAML and it’s working now.