Streaming Reolink Camera to Lenovo Smart Clock

Currently in my setup I have 2 Reolink Camera’s in my network, both are connected via IP and got a static IP addres. Everything is working fine within Home Assistant besides the delay from the streaming what is roughly ± 6 seconds.

I exposed also my camera’s to the Google Assistant component and I can see them in my Google Home App.
Once I ask to stream my Camera I see for like 1 seconds a Live Stream and then it suddenly is paused.

More people having issues with seeing the camera’s on the Google Hub or other smart devices.

My setup:

 #Enable stream

  - platform: reolink_dev
    name: Voordeur
    username: admin
    password: !secret camera_voordeur
    stream: main
    protocol: rtmp
    scan_interval: 5

  - platform: reolink_dev
    name: Achtertuin
    username: admin
    password: !secret camera_achterdeur
    stream: main
    protocol: rtmp
    scan_interval: 5

  project_id: xxx
  # api_key: xxx
  service_account: !include HomeAssistant-xxf.json
  report_state: true
  expose_by_default: false
      expose: true      
      name: Camera Achtertuin
      expose: true      
      name: Camera Voordeur  

Have you tried the sub stream for a more flued response.

Thanks for your feedback even with the sub rtmp stream same issue.

Changed already on my Reolink Camera the image quality to 4fps and max bitrate 64 kbs.
Didn’t worked out.

Temporary connected my Reolink Camera to the internet and connected via the Reolink Cloud to my Google Home and smooth camera view without any issues.
So feeling wise somehow mist this be related to Home Assistant only no idea how to fix this :frowning:

Im assuming the rtsp is the same,
I dont have google so i cant try. Alexa doesnt even see my Reolinks unless i use the cloud.
But you could try generic, or onvif to see if it is just the way HA talks to google