Stuck at login after creating account on fresh installation of Home assistant

I’ve wanted to use home assistant for while now but I keep running into the same problem.
That I cannot access home assistant from my browser most of the times it starts after creating the account but it never goes to the next page but returns to the login page.

On some of my installs it goes trough to the dashboard and after a couple of minutes it throws me out and I can never login again.

I’ve tried a lot of different solutions provided on the forum but most don’t work and some work for a short period before I get thrown out again.

And I really don’t know what to do now, so does anyone how I can resolve this?

How are you installing it, what device, what distribution etc? Never had any issues on a rpi or x86 machine.

On my last couple of installs I created a vm in proxmox using the provided qcow2 file from home assistant. but had the same problems with RPI and running a container in docker on top of debian distribution as well as in Raspbian .

When looking in the logs I get the following warning when I try to login.

WARNING (MainThread) [homeassistant.components.websocket_api.http.connection] [140426760679248] Disconnected: Did not receive auth message within 10 seconds

other times it says unauthorized login detected.

I already tried configuring trusted networks and users, long-Lived access tokens but those didn’t help.