Stuck at "Preparing"


I must apologise. This is a duplicate post. I’ve read this post on several locations (both on the Home Assistant Communities and elsewhere on the net). There is no documented definitive solution.

About 5 miuntes after I run up my HassIO install, it takes an IP address from my DHCP server (as it should). I browse to port 8123 at that address and I get the “Preparing” message. I wait 20 minutes. I wait 40 minutes. Last night, I waited overnight (that was 7 hours).

I’ve tried mutiple RPis, I’ve tried clearing my browser cache. I’m about to try a manual install.

One thing worries me. In the installation instructions, we’re told to flash the image to an SD card and also create a USB stick with the network config on.

> 3. WiFi and Static IP setup only: Format a USB-Stick with name CONFIG , create a folder named network and within that folder a file named my-network . Copy one of [the examples] to the my-network file.
> 4. Unmount the SD card and remove it from your SD card reader.
> 5. Insert the SD card into your Raspberry Pi 3. If you are going to use an Ethernet cable, connect that too.
> 6. Connect your Raspberry Pi to the power supply, so it turns on.

At no time are we told to put the USB stick in the RPi. I’m being pedantic, yes, but some folk have said removing USB peripherals (I have none) allowed their installations to progress.

I’ve not used this USB stick method, anyway, but I assumed the default DHCP route would b OKay.

How do we get past the “Preparing” web screen? Has anyone actually solved this, please?

If you are using wired ethernet, then DHCP should work fine. At some point, you will want to reserve that address, but you should not need to do anything else for installation.

You can connect a display via HDMI along with a USB keyboard to see if there are any errors displayed.

The reason for allowing the DHCP install was that I was hoping not to hook up a terminal. I would reserve the address after the initial install. OKay, having hooked up a terminal, there’s nothing I recognise as an “error”.

It seems to be repeating eth0: renamed from …
hassio: port3 entered blocking state
hassio: port3 entered forwarding state
wlan0: link is not ready
IPv6: eth0: link becomes ready

Which, I think, is all fine.

Got it working by connecting a display and keyboard to the RPi and executing ha supervisor repair.