Stuck at "Preparing Home Assistant"

I’ve used Home Assistant for a long time. I started with and got frustrated with it crashing and not being able to get any details, so I reinstalled manually and that worked well. It was a little less convenient having to configure everything and the add-ons I needed (like mqtt and nodered). I recently had my SSD card get corrupted (I run on a raspberry pi) and thought I would use the OS approach.

I have created SSDs for pi 3 32 bit and 64 bit and run on an pi 3 B+. Those come up and get to onboarding, but certain components do not work, and eventually the supervisor dies. given the python errors I was seeing something is not installing correctly.

I then created SSDs for pi 4 32 bit and 64 bit and run on a pi 4 2GB. Those get to the “Preparing Home Assistant” screen and never seem to do anything else. Is there any way to get to the pi when it is in this state to do anything about it? I’ve found some older versions that seemed to have this issue, but the fix seemed to come in the next release.

Anyone with any thoughts/tips/ideas?


I think there should be a blue dot that you can click on while it’s preparing to see the progress.

Beyond that, you can log in with root: Common Tasks - Operating System - Home Assistant
And then ha su logs and ha core logs to see what’s going on: Common Tasks - Operating System - Home Assistant


Looks like it is having an issue connecting back to itself to install a docker image?

21-02-02 22:37:44 INFO (SyncWorker_1) [supervisor.docker.interface] Updating image homeassistant/raspberrypi4-64-homeassistant:landingpage to homeassistant/raspberrypi4-64-homeassistant:2021.4.6
21-02-02 22:37:44 INFO (SyncWorker_1) [supervisor.docker.interface] Downloading docker image homeassistant/raspberrypi4-64-homeassistant with tag 2021.4.6.
21-02-02 22:37:51 WARNING (MainThread) [] Can't update connectivity information: Error: Timeout was reached
21-02-02 22:37:59 ERROR (SyncWorker_1) [supervisor.docker.interface] Can't install homeassistant/raspberrypi4-64-homeassistant:2021.4.6 -> 500 Server Error for http+docker://localhost/v1.40/images/create?tag=2021.4.6&fromImage=homeassistant%2Fraspberrypi4-64-homeassistant: Internal Server Error ("Get "": context deadline exceeded (Client.Timeout exceeded while awaiting headers)").
21-02-02 22:37:59 WARNING (MainThread) [supervisor.homeassistant.core] Error on Home Assistant installation. Retry in 30sec

Seems like it would have to be getting that image from somewhere…the device has connectivity, and I see some activity, but certainly not enough to download a docker image.

I did try to go to this site it mentions, but it responds with authentication needed:

{"errors":[{"code":"UNAUTHORIZED","message":"authentication required","detail":null}]}

I gave up. I read several posts where people were able to downgrade from the console to 4.2 and then things were working and updated after that. I could not get that to work, but creating an SD card with the 4.2 image seems to be working.