Stuck on Home Assistant Command line

I’ve been setting up HA on an old Chromebook I have.

I’ve managed to install Home Assistant, but when I boot it up it goes into the command line, but I can’t type anything.

The machine doesnt have an ethernet port, so I can’t access the URL since it still isn’t on my WiFi.

What am I missing ?

Acer Chromebook 14,

You better install Home Assistant OS on a dedicated hardware with a LAN port.

If you want to run HA on your laptop, the best way is to install a full Linux distribution and then run home Assistant supervised or core.

(Or simply use USB to Ethernet adapter)

HA OS is meant to be headless

You can also try the following methods (using nmcli), but you may have drivers issue

I do realize that I better use a dedicated hardware, and was planning on getting a Raspberry Pi for that, since they are globally unavailable I started to look at my other options, and I do have this old Chromebook sitting around doing nothing and I found a very useful guide on how to set up HAOS on a Chromebook device.

I have successfully set up home assistant. However my issue is that keyboard input isn’t working. I was planning on using nmcli to connect it to my wifi. For that I need to be able to type into the command line. After that everything else can be done from a remote computer.

I might try to pick up a USB to Ethernet adapter tomorrow to see if that works.

I came here to check two things:
1: I am supposed to be able to type into the command line of HAOS ?
2: Is there a known issue with keyboards not functioning with HAOS ?

It might sound like a dumb advice but have you tried a USB Keyboard?

You should be able to access the cli from the keyboard and monitor attached to HA Os, but there’s maybe a hardware issue

I tought about it, don’t have one one hand at home but I’ll take the laptop with me to work tomorrow, there are some keyboards lying around there. I’m pretty sure there’s also an USB to Ethernet adapter ther that I can try.

There’s also the Waiting for CLI to be ready that may interfere you can try to change TTY (oups I missed read the screen, the cli seems to be ready)

Another solution is that a cellphone may acte as a WIFI to USB bridge, you would be able to use your phone to go to HA setting and set the WiFi of your laptop

External keyboard worked, and with an USB to Ethernet adapter I was able to connect.

Any suggestions for trying to solve this… It’s technicly a non issue since I’ll just connect it and leave it running.

I guess it’s just a driver issue, your integrated keyboard isn’t recognised by HA OS, since HA OS is meant to be mostly headless no one will bother making work on laptops.

Now that you were able to access interface you can try to setup WiFi but anyone would suggest to stay wirered

I’m connected to WiFi and I’ve bought a USB to Ethernet adapter.

The place I’m planning on keeping it isn’t yet ready, so it’s in a temporary spot, connected to wifi. Then going to it’s final resting place later where it will be wired :slight_smile:

I have the exact same message on my raspberry pi.
I tried reformatting my disk, re imaging it. Can’t get it to boot up normally on a raspberry pi 4. Any help
Would be appreicated

I think it’s meant to look like that on the HA device.
log in
Log in to this address with your phone or PC.

It’s not always intuitive to new users, but HA is designed to run as a server (on your Pi in your case.) It should run there 24/7, so it can monitor and control all the devices you will set up. You don’t access HA from the server (your Pi) itself, but from any other devices on your network you like, in a regular browser by using the IP address.