Stuck on "Preparing" on Raspberry Pi 4

Hi everyone, I’ve had running on a Raspberry Pi 3B+ for a while now, working great. Today I got a new Raspberry Pi 4 and have been having trouble getting it to work. Here’s what I did:

  1. Went to and downloaded “(Beta) Raspberry Pi 4 Model B 32bit”.
  2. Used balenaEtcher to flash the image on a 32GB microSD card.
  3. Put the microSD card into my Raspberry Pi 4 and connected a monitor, keyboard, ethernet, and power cables.

I saw a lot of messages on the monitor, but nothing that stood out as an error, just many things initializing and starting up. I went to http://hassio.local:8123/ as well as the local IP address for the Raspberry Pi (which I found from my router). Both led me to screen that says “Preparing (this can take up to 20 minutes)”.

I waited over 20 minutes, at least an hour, but the screen was still there. At this point I tried:

  1. Reflashing the same microSD card.
  2. Reflashing an identical but different microSD card.
  3. Assigning the Raspberry Pi a manual static IP from my router.
  4. Forwarding port 8123 to the static IP.
  5. Restarting the router.

At this point I can still see the same “Preparing” screen.

I can see “” on the client list of my router, but it has no access time and no TxRate or RxRate like all the other clients.

Can anyone give me some tips how to debug or what to try next? Is there anything I should look for in the text that comes up when it boots? Or are there any logs I can investigate on the microSD card?

Edit: Figured it out, I had to login with the user “root” and no password to the Raspberry Pi and then manually run “homeassistant rebuild”. Tried this with both microSD cards and it fixed the install on both of them.

1 Like

Could you possibly explain to me how this is done, im having the same issue and I don’t know alot about what I’m doing.